Topic: Odd Flickr problem

So I've successfully got it to work with my Flickr account, but it only works if I dont specify tags. If I do specify a tag, only one or no images at all are being loaded, yet my flickr account is full of images with the tags I'm using.
Any ideas why?

here's my setup:

        fo.addVariable('user_id', '24421388@N02');
        fo.addVariable('tags', 'colour');
        //fo.addVariable('tag_mode', 'all');

I noticed that while commenting out the tag options gets my Tiltviewer to display my entire Flickr stream, specifying tags always displays the same two images. I actually removed *ALL* tags from one of these images and It's still displaying.

For instance, the tag "comix" on my Flickr profile produces many results:
http://www.flickr.com/photos/24421388@N02/tags/comix/

Yet if I use:

                fo.addVariable('user_id', '24421388@N02');
        fo.addVariable('tags', 'comix');

... I only get one image to display. whyyyy sad???

Also, I tried someone else's ID with some tags that apply to multiple images in their gallery and it works fine. I dont understand why it isnt working properly with my tags. On Flickr, i can actually browse my images according to the same tags I'm trying to use with TiltViewer and it works normally. *sigh...*

Re: Odd Flickr problem

http://www.flickr.com/photos/24421388@N02/tags/comix/ only show 1 image here. Perhaps some of your images are private?

Felix Turner
SimpleViewer Support Team.

Re: Odd Flickr problem

Thanks for checking the link. I clicked on the very same link but I see all the images, not just one. I logged out of Flickr and I still see them all, they are all public.

This is a clue I suppose... you see only one image, just as Tiltviewer does. I dont get it.... Does everyone only see one image when clicking on the link?

Re: Odd Flickr problem

I see 19 images.

Re: Odd Flickr problem

Damn this! Now I see no images at all in Tilt Viewer.

Here is the page where I'm displaying my gallery:

http://www.raisinlove.com/flickr.php

This will display all my images from my Flickr stream, as I haven't specified any tags. You can see in the sourcecode the variables are for the default Flickr feed.

I added a little PHP line to test out tags, so if you add a tag in the url, it will insert the flash variable line for tags:

http://www.raisinlove.com/flickr.php?tag=sketchbook

As you can see in the source of the page, all this query string does is add the line:

fo.addVariable("tags", "sketchbook");

... yet no images are being displayed! This is puzzling since even simlev1 can see all 19 images tagged "sketchbook" in my Flickr feed.

Any ideas?

Re: Odd Flickr problem

When I visit this url: http://www.flickr.com/photos/raisinlove … ketchbook/
I see this: "raisinlove doesn't have anything tagged with sketchbook." So there is something going on with Flickr. Are your image public?

Felix Turner
SimpleViewer Support Team.

Re: Odd Flickr problem

The Flickr people think it has to do with content type (art/illustration VS photos) but i set all my art/illustration images for public viewing. Also, that theory doesnt work since for some tags, TiltViewer *does* display artwork (as opposed to photos). For instance:

http://www.flickr.com/photos/raisinlove/tags/personal/

You should see a bunch of images with the above tag search. Can anyone confirm that indeed more than one image comes up?

When I use the "personal" tag for TiltViewer however, only one image comes up:

http://www.raisinlove.com/flickr.php?tag=personal

Thus, the problem seems to be in the way TiltViewer is handling my Flickr stream. I'm not giving up on this, I want TiltViewer as my website's main feature!

Re: Odd Flickr problem

Still in support of raisinlove's arguments, I see 25 pics at flickr/.../sketchbook, 45 at flickr/.../personal and just one in his flickr.php?tag=personal

It would be interesting to find out why e.g. Felix doesn't see the same as I.

Re: Odd Flickr problem

And without the ?tag= parameter, TiltViewer shows a lot of pictures...

Re: Odd Flickr problem

Thanks for checking simlev1, now I know the problem isn't on the Flickr side. Maybe Felix has the art/illustration filter on?

And without the ?tag= parameter, TiltViewer shows a lot of pictures...

Yes, this seems to confirm the problem lies with TiltViewer's tag input specificaly. Maybe there's some other info to take into account in the ActionScript. Maybe I could try and dig into it if I purchase TiltViewer Pro for the fla source file...[/b]

Re: Odd Flickr problem

Afaik TiltViewer Pro doesn't include the source code; that requires a different licence and I don't know how much it could cost. I would like to have a look at the fla, too, but it can be expensive and there's no guarantee that I would be able to add the features I want with just minor modifications...

Re: Odd Flickr problem

Bummer... I do hope Felix has time to check this if no one else has access to it.

Re: Odd Flickr problem

My Flickr account did not have 'Include art, illustration, CGI and other non-photographic images in search results' checked (the default). Since I checked it I see your images.

So it looks like flickr by default does not return images marked as illustrations in search results. Can you un-mark the images as illustrations?

Felix Turner
SimpleViewer Support Team.

Re: Odd Flickr problem

Thanks Felix.
I changed the content type of the images and it now works! But I dont understand why, since I could see them when I wasn't logged into Flickr.

In any case, this isn't ideal, since Flickr requires accurate content type for images. Surely there's a way around this, to ensure images marked as illustrations are properly read in?