Topic: Adding a Custom PHP.ini file error

Hi

I dont have direct access to my PHP.ini file using strato as my webhost, I have emailed them about increasing the numbers for uploading as at present it is set to 8mb.

However doing some research on the net, and in a link found on the Strato help pages, a suggestion was made about the ability to create a PHP.ini file that can go into other locations for specific domains and applications. I have created a PHP.ini file that i then placed in my svmanager directory, however when i try to log in to admin on my site i get the following error:

Fatal error: session_start() [<a href='function.session-start'>function.session-start</a>]: Failed to initialize storage module: files (path: ) in /mnt/web7/53/62/51959462/htdocs/Beaney/svmanager/classes/auth.php on line 44

If I remove the php.ini it works again, any ideas how i can use this PHP.ini get around? should I be placing it elsewhere or should I hope that Strato give me access or upgrade it for me? Bit annoying as I was with Lycos before and I could access it there, and as they shut down i transferred to Strato, which I'm regretting each day!

Regards

James

Re: Adding a Custom PHP.ini file error

For debugging problems like this I find it useful to create a php file that just contains one line:

<?php phpinfo&#40;&#41; ?>

You can copy the file into the directory of interest and run it to get a nicely formatted list of php.ini settings (you may know this already but others might be interested).

Is your new php.ini a copy of the old one or did you create it from scratch? It's usually better to copy the working version if you can get to it or at least compare the original phpinfo() output to the modified one.

SvManager is bombing-out when it tries to run the php session_start() function so the place to look is in the Sessions area of your new php.ini settings. Maybe sessions are not enabled in your new file or maybe the session save path is wrong.

Having said all this, do you really need more than 8MB? Couldn't you just downsize the images a bit? Or let svManager downsize them for you on the upload screen?

jack

Jack Hardie
SimpleViewer Support Team.

Re: Adding a Custom PHP.ini file error

Hi

Thanks for that I'll look into creating the php file to see whats going on, reference the php.ini i created it was from scratch, so that maybe where the issue is as there is no reference to the sessions. Issue I have at present is that Strato dont allow access to the PHP.ini so copying from the original is a bit hard, but Im sure somehow i'll find a similar php.ini on the net somewhere, so annoying that hosting companies prevent accesss to these files.

With regard to image size settings, i can cope with 8mb for individual image size to some extent main issue is the overall upload size, bit slow and annoying having to drag and drop over and over when lots of files in a gallery.

Thanks for you info, great product by the way, just getting into it at the moment, but looking forward to customising more. Think it would be a neat feature still though incorporating some form of user account settings, so can do a setup for multiple users correctly.

Regards

James

Re: Adding a Custom PHP.ini file error

Ok all is solved now.

I think it was to do with the way i was increasing the two sizes and my understanding of which one did what.

I've now created a php.ini file placed it in my svmanager directory, and set the sizes as such

post_max_size = 100M
upload_max_filesize = 95M

max_execution_time = 600 (needed to increase this to stop it timing out as uploading larger amount.

it all now works, in the add images tab it shows 95MByte as the maximum size for one upload!

Hope this helps others who are unable to directly edit their PHP.ini