Topic: Script error in CS4 plug in

I'm creating simpleviewer galleries in Photoshop CS4, and they show fine locally, but when uploaded I get the 'needs flash and java' message.

I have downloaded simpleviewer independently, and each time i create a gallery, I replace all of the files aside from xml and thumbs with files from the new download.  This works fine, so im assuming that there is a problem with the original script for the photoshop plug in.  The problem is, i have no idea how to find or replace them! 

Is there any way to just replace the files for photoshop with the new files I have downloaded. 

I hope this makes sense, Im truly bumbling my way through here!