Topic: Upload Test Problem

Im having a problem with the Upload Test for svManager. Ive been through the first two stages of the test program with no problems, but when I try to use the upload applet I cant upload anything. I upgraded to the latest version of Java, restarted my browser, and tried refreshing my browser after trying an upload, and nothings seems to have helped.

The upload process works to a point, I can select an image (I tried with a very low res image) and open in and I get the progress bar, and when its finished progressing the progress box disappears and I go back to the empty upload box, with nothing indicating that the file was uploaded in any way.

Im using Firefox version 3.0.9 if that helps at ll. Any suggestions you can offer would be great thanks,

Re: Upload Test Problem

What normally happens is you should see a message appearing under the uploader with a list of uploaded images.

Can you use ftp to check if the images are actually being uploaded? They should be in the svmtest/uploads folder. Each time you try an upload then svmTest should first empty this folder and then copy the new images in there.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Upload Test Problem

Hi Jack,

Thanks for that but I never got any message about the uploaded images, and I just checked the uploads folder and its completely empty.

Any other suggestions I could try out would be great thanks

Susy

Re: Upload Test Problem

The puzzle here is why you are not getting any error messages. Do you have access to the server logs via your ftp program? I know they are a bit long and intimidating but if you try an upload and look at the server log for the time you did it then you should see the server responding to a browser request for the upload page and for the two java .jar files. You might also see an error message that would give a clue as to what is happening.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Upload Test Problem

hi Jack,

I cant find the server logs through FTP, and had a look through the cPanel for them too, but couldnt find anything that seemed right. Ive contacted the hosting provider to get help, but if you have any other bright ideas in the meantime Ill happily try them out....

It seemed odd to me not to get an error message too, but I just tried the upload test again to be sure and nothing at all appears except the 3mb limit message. Sorry!

Re: Upload Test Problem

Hi!

Ive managed to get into the server error logs but cant find anything that matches the domain name or my IP address, so still havent gotten much closer.

These two error messages seem like the most likely to be relevant:
Premature end of script headers: icad.pl
Premature end of script headers: 500.php

Dont know if that helps any but thought there was no harm in sharing.

Thanks

Re: Upload Test Problem

Mmm, all that means is that there is an internal server error somewhere but we don't know why.

I've just updated svmTest to the latest version of the java applet. I've also set the error reporting a little differently. Trouble is that if server errors are occurring in a script called by the Java applet then they might not show.

Anyway, it's worth a try to download the latest version of svmTest from the Airtight Interactive web site and install it. When you upload it to your site make sure that all the php scripts are being uploaded in ascii mode not in binary – there will be a setting somewhere in your ftp program. After the upload, make sure that all the folder and file permissions for svmTest are ok. Empty your browser cache, cross your fingers and try again.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Upload Test Problem

Hi Jack,

Sorry about taking so long to reply this, I finally discovered the problem, it wasn't on your end at all, the name servers were supposed to have been changed to point to the correct server but they weren't correctly. Which explains the lack of any error messages or anything. Since we've got that all fixed the full test runs perfectly. Thanks a million for all the help and advice, and sorry to have caused so much hassle.

Thanks,
Susy

Re: Upload Test Problem

No worries. I think you win the prize for obscure problem of the month  smile

jack

Jack Hardie
SimpleViewer Support Team.