Topic: caption target only Blank ??? Parent, self not working!?

Hi guys ive just set up my gallery.
all is going well but i have one prob.
Im linking from a Caption to a page, but i want it to link
tot that page in the same window. Somehow its not working.
I keep ending with a new window ?

This is my code at the moment.

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="1280" maxImageHeight="768" textColor="0xffffff" frameColor="0xffffff" frameWidth="20" stagePadding="40" navPadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="left" vAlign="center" hAlign="center" title="" enableRightClickOpen="false" backgroundImagePath="background.jpg" imagePath="" thumbPath="">
<image>
    <filename>Barn_DAli.jpg</filename>
    <caption><![CDATA[<A href="../index2.html" target="_self.">
<U>Close Full Screen</U></A>]]></caption>
</image>
<image>
    <filename>Bike.jpg</filename>
    <caption><![CDATA[<A href="../index2.html" target="self.">
<U>Close Full Screen</U></A>]]></caption>
</image>
</simpleviewerGallery>


Do you see the problem?
Thank you so much! smile

Re: caption target only Blank ??? Parent, self not working!?

use:

 target="_self"

without the period.

Felix Turner
SimpleViewer Support Team.

Re: caption target only Blank ??? Parent, self not working!?

Hi thanks for the reply
Unfortunatly that doesnt work.
On mouse over you can see its a link, but when you click
nothing happens...
It keeps at the gallery page.

Ive tried many kinds, with and without periods, no effect
Im clueless to why it doesnt work...?

Re: caption target only Blank ??? Parent, self not working!?

Ive been trying every option imaginable, but no succes.
Am i the only one here with this problem? Every gallery
were i add a text link in the caption makes it open up in a new window
i can not get it to open in the same window. Im using the correct html tags.

Please help me out!

Re: caption target only Blank ??? Parent, self not working!?

i cant seem to fix my caption problem, if i link to a page i can only
open it up in a new window not in the same window.

Hi,

I just verified that opening links in the current window is working with the latest version of SimpleViewer. The caption tag should look like this:

<caption><!&#91;CDATA&#91;<u><a href="http&#58;//www.google.com" target="_self">open link in current window</a></u>&#93;&#93;></caption>

Note that this may not work when testing locally. This is due to a security restriction in the Flash Player. Please test your files online.

Felix Turner
SimpleViewer Support Team.