Topic: 100% cpu speed and never stops loading

Hi,

I have a problem installing tiltviewer pro. When i was using the demo the animation was fast and smooth. Now I have replaced the swf file whith the pro-one and my cpu goes 100% while using tiltviewer. Now the animation is far from smooth, and people with slower pc's are having trouble using tiltviewer.

Also my browser keeps loading the page. The green bar below (IE7) never goes away...

Anybody got a clue? Below is the code I use.

        var fo = new SWFObject("TiltViewer.swf", "viewer", "100%", "100%", "9", "#000000");
        
        fo.addVariable('useFlickr', 'false');
        fo.addVariable('columns', '7');
        fo.addVariable('rows', '5');
        fo.addVariable('linkLabel', 'projecten voor deze klant »');
        fo.addVariable('showLinkButton', 'true');
        fo.addVariable('zoomedInDistance', '1400');
        fo.addVariable('zoomedOutDistance', '5000');
        fo.addVariable('fontName', 'Century Gothic');
        fo.addVariable('titleFontSize', '70');
        fo.addVariable('descriptionFontSize', '27');
        //fo.addVariable('linkFontSize', '41');    
        //fo.addVariable('textColor', '0xFF0000');
        //fo.addVariable('linkTextColor', '0x00FF00');
        //fo.addVariable('linkBkgndColor', '0x0000FF');        
        //fo.addVariable('frameColor', '0xFF0000');
        fo.addVariable("backColor", "0xd12365");
        fo.addVariable("bkgndInnerColor", "0xffffff");
        fo.addVariable("bkgndOuterColor", "0x868686");    
        //
        // FLICKR GALLERY OPTIONS
        //fo.addVariable('user_id', '48508968@N00');
        //fo.addVariable('tags', 'jump,smile');
        //fo.addVariable('tag_mode', 'all');        
        //fo.addVariable('showTakenByText', 'true');
        //
        // XML GALLERY OPTIONS
        fo.addVariable('xmlURL', '/gallery.xml');        
        fo.addVariable('maxJPGSize', '640');        
        fo.addVariable('linkTarget', '_self');
        //
        // END TILTVIEWER-PRO CONFIGURATION OPTIONS
        
        fo.addParam("wmode","opaque");
        fo.addParam("allowFullScreen","true");
        fo.write("flashcontent");    

Re: 100% cpu speed and never stops loading

The performance of the free SWF and the Pro SWF is identical. Try switching out the SWFs to verify this.

Flash by default will use all available CPU resources so don't worry about the CPU usage graph.

Felix Turner
SimpleViewer Support Team.