Topic: multiple_gallery and svManager image path error

I have SimpleViewerPro and svManager installed.

My "Path from web root" in admin is like this:
/galleries/2004/
/galleries/2005/
/galleries/2006/
etc...

I am getting error in flash when compiling multiple_galleries.fla that says:
Error opening URL 'file:/galleries/images/picture1.jpg'

How do I fix the path so that it looks in /galleries/XXXX/images/picture1.jpg where XXXX is the taken from "Path from web root". It seems like it isn't doing what it should. If it used "Path from web root" and appended "/images" to that it should work, but the path in gallery.xml is simply "images/". I have rebuilt galleries with no luck.

The xml file is named 'gallery.xml' and 1 exists in each years folder. svManager creates it there and updates it there. So to use the multiple_galleries example from SimpleViewerPro, I changed the xml path to:
_root.xmlDataPath = galleryId +"/gallery.xml";

That seems to work fine. The xml file gets loaded, but when it tries to get the images, it can't because the xml file has:
imagePath = "images/" thumbPath = "thumbs/"

It should be:
imagePath = "2004/images/" thumbPath = "2004/thumbs/"
imagePath = "2005/images/" thumbPath = "2005/thumbs/"
etc...

Any idea how I fix this? Thanks for ideas on what I did wrong?

Chris

Re: multiple_gallery and svManager image path error

I've been mulling this one over for a day or two but I don't think it's possible to fix it from the svManager end of things.

The example from the SVPro download has two different xml files in the same folder (gallery1.xml and gallery2.xml). I can't think of a way to make SvManager work with this structure.

It must be possible to tackle it from the Flash end of things and retain a structure that svManager can work with but I'm not the best person to advise on this – have you tried the SimpleViewer Pro forum?

I would use html for the multiple gallery menus but I appreciate that there may be reasons why you prefer Flash.

Sorry not to be more help – any Flash gurus out there who can help?

jack

Jack Hardie
SimpleViewer Support Team.

Re: multiple_gallery and svManager image path error

The example from the SVPro download has two different xml files in the same folder (gallery1.xml and gallery2.xml). I can't think of a way to make SvManager work with this structure.

I understand that the xml files are named gallery1.xml and gallery2.xml in the example.
I have modified the Actionscript in the .fla file so that it instead uses gallery.xml from every separate directory (gallery). So that part is done.

What I need, is to modify some code so that when building the .xml files (svManager) will add the full path (Path from web root) to the xml file, rather than just "images/" and "thumbs/".

Hope fully I am understood. I can currently just change the paths in the xml file and it works. This is fine for my older galleries as they won't change, but when adding new images, it will break the xml file for the current "year's" gallery.

Thanks again for any assistance.
Chris

PS. Is posting in SimpleViewerPro forum considered double posting :-)

Re: multiple_gallery and svManager image path error

Have you seen the section on Relative and Absolute Paths in the Advanced section of the user manual? Does this help?

jack

Jack Hardie
SimpleViewer Support Team.