Topic: It's not IE it's me but it works in firefox!

Argh... what am I doing wrong!? smile

I am using simpleviewer on my website (scythewear.com/photos.htm) and it works when viewing it in Firefox or Safari.
When using IE I get the "SimpleViewer requires JavaScript and the Flash Player. Get Flash."

Naturally I first thought maybe it's IE but then I find another site that uses simpleviewer (westvalleymemorialride.com) so I tried viewing their photos with IE and it works!

Help please.

Re: It's not IE it's me but it works in firefox!

It seems your version of swfobject.js is to blame.
Replace your swfobject.js with the one that comes bundled with the SimpleViewer download and all should be well.

Steven Speirs
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

I am using the swfobject.js that comes with the bundle.
Could it be because I renamed the gallery folder?
But still, firefox and safari can view it... I'm lost. yikes(

Re: It's not IE it's me but it works in firefox!

The swfobject.js file at:
http://scythewear.com/guidedogz09/swfobject.js
... is not the same as the one found in the download package at:
http://www.simpleviewer.net/simpleviewer/
I downloaded your swfobject.js file and tried it locally on my PC in a gallery.  The gallery did not display in IE.
As soon as I swapped it over for a fresh swfobject.js (from the SimpleViewer download), the gallery worked.

Steven Speirs
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

that's odd but ok I will try it thanks!

Re: It's not IE it's me but it works in firefox!

Downloaded the swfobject.js file and added it to my site but it is still the same.
I'm lost.

HELP!!

Re: It's not IE it's me but it works in firefox!

I'm still convinced that your swfobject.js files are causing the problem.
However, the fact that you've uploaded fresh ones to your web site makes me think that the problem might occur during upload to your site.
It looks like the js files have been compressed (line breaks have been removed) and the leading comments have been stripped out.
Check with your host to see if they automatically compress JavaScript files and see if this feature can be turned off.

Steven Speirs
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

Yeah, I guess that makes more sense but I still don't know why Firefox or Safari is fine with it.
By the way, if I have it setup locally on my PC, I can use any browser and it works.

I feel a long battle with MSN is about to begin. sad

OK, thanks for the help.

Re: It's not IE it's me but it works in firefox!

Firefox tends to be more forgiving if there is an issue/error and IE just breaks. If I go to http://scythewear.com/guidedogz09/viewer.swf in ie it almost functions. So it does look like the SWFObject.js is the issue. If you go to http://scythewear.com/guidedogz09/swfobject.js the file looks like it is missing information, things like this can happen where a FTP app or a firewall eat a file. One quick experiment you can do is make this change in your HTML file. Change src="swfobject.js" to src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js" then clear your cache and
see if it works. If it does work you can either keep the change or re-upload SWFObject.js, but this time try a different FTP app.

Mike Richards
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

I will try that tonight and post tomorrow... thanks!

Re: It's not IE it's me but it works in firefox!

What miker suggests is a good idea (linking to a known working copy of swfobject.js).
However, changing src="swfobject.js" to src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js" won't work as SimpleViewer is bundled with swfobject v1.5 (and the syntax on your pages is also for v1.5) and the link is for v2.2 which is not backwards compatible with v1.5.
I've not found a link to v1.5 that would be acceptable to use on a permanent basis but for the purposes of a trial, I've uploaded v1.5 so try:

<script src="http://testgallery.110mb.com/swfobject/swfobject.js" type="text/javascript"></script>
Steven Speirs
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

I have never had any issues with version 2.2.

Mike Richards
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

SimpleViewer is compatible with swfobject 2.2.
However, the documentation at http://code.google.com/p/swfobject/wiki/documentation states that swfobject 2 is not backwards compatible with swfobject 1.5.
ie the embedding code in the html page for 1.x has a different syntax than that for 2.x and the code must match the version of swfobject being used.
Just to check, I swapped the swfobject.js 1.5 file (from the sample gallery in the SimpleViewer download which uses 1.5 style code) with swfobject.js 2.2 and the gallery broke.

Steven Speirs
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

It worked... but I don't know what actually did it.

This is what I did last night:

1. Cleared my cache.
2. Added <script src="http://testgallery.110mb.com/swfobject/swfobject.js" type="text/javascript"></script> ONLY to my guidedogs gallery.

Tried it again and all worked fine. When I say all I mean even the galleries that did not get the html change.

I thought maybe clearing the cache actually did the trick until I got to work, using a different PC. I thought maybe I have to clear its cache too but nope! It work on every other PC I tried it on.

What did the trick? Regardless... I'm happy I didnt have to get MSN involved!

THANKS A BILLION (adjusted for inflation) GUYS!!!

Re: It's not IE it's me but it works in firefox!

It was the new copy of SWFObject that did the trick. Glad to hear it worked out for you.

Mike Richards
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

Mine works great with any browser. Never had any problems with it. Anyway, glad to know your issue has been resolved.

Regards,
Jay
Pret travaux

17

Re: It's not IE it's me but it works in firefox!

hi,
i have also a problem with ie but your solution does not work in my Homepage :-(
Please can anyone see to my site: http://www.maler-angerer.de/referenzen/referenzen.html . In firefox works all fine but in ie not. http://www.maler-angerer.de/referenzen/index.html generated with skript from Photoshop CS3 works fine with both browsers.

Regards
Lae

Last edited by Lae (2009-09-14 10:04:38)

Re: It's not IE it's me but it works in firefox!

Replacing version 1.5 by version 2.2 gives a bad result in both browsers IE and Firefox.

Error: swfobject undefined. (coding "SWFObject" as needed for version 1.5 gives the same)

The gallery is created by Photoshop CS3 and the exe file is replaced manually.

Where is the cause?

Re: It's not IE it's me but it works in firefox!

After a three days search: problem solved!!!!

While integrating a Simpleviewerscript made by Photoshop don't use FLOAT=Left (or right) in HMTL. Otherwise things will block in Firefox.

Kind regards.

Re: It's not IE it's me but it works in firefox!

Sadly I've got the issue as well where it works in Chrome & Firefox but not in IE. I've used v1.9 of simpleviewer when created.

Link to one of the pages where I use simpleviewer: http://www.celsydney.com/red-carpet/borat/article8.html

If someone could please have a look what might be the cause that would be much appreciated! smile

Re: It's not IE it's me but it works in firefox!

start by removing this:

<embed type="application/x-shockwave-flash" src="viewer.swf" style="" id="viewer" name="viewer" bgcolor="#181818" quality="high" wmode="transparent" height="100%" width="100%"><a style="left: 1136px ! important; top: 873px ! important;" title="Click here to block this object with Adblock Plus" class="szhmqjamqbqljudfsfgx" href="http://www.celsydney.com/red-carpet/borat/viewer.swf"></a>
Mike Richards
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

Is that a line in the source that needs to be removed?

Sorry, I'm very new to this so not too sure. I can't find that line in the page source.

Re: It's not IE it's me but it works in firefox!

the line is in this, http://www.celsydney.com/red-carpet/bor … cle8.html,  HTML doc.

Mike Richards
SimpleViewer Support Team.

Re: It's not IE it's me but it works in firefox!

I really can't find the line in the source of that page neutral

I've looked everywhere and did a 'find' (ctrl F) on the source as well, but nothing...

I appreciate your assistance Mike

Cheers,
Marcel

Re: It's not IE it's me but it works in firefox!

Looks like you found it, it had been on line 62, but it's fixed now. I think the issue is now this:

<script type="text/javascript"
src="http://www.statcounter.com/counter/counter.js"></script><noscript><div
class="statcounter"><a title="iweb stats"
href="http://www.statcounter.com/iweb/" target="_blank"><img
class="statcounter"
src="http://c.statcounter.com/5093999/0/a9daa818/0/"
alt="iweb stats" ></a></div></noscript>
<!-- End of StatCounter Code -->
</center>    
</body>
</html>

should be:

<script type="text/javascript" src="http://www.statcounter.com/counter/counter.js"></script><noscript><div
class="statcounter"><a title="iweb stats"
href="http://www.statcounter.com/iweb/" target="_blank"><img
class="statcounter"
src="http://c.statcounter.com/5093999/0/a9daa818/0/"
alt="iweb stats" ></a></div></noscript>
</script>
<!-- End of StatCounter Code -->
</center>    
</body>
</html>

You see additional HTML errors here.

http://validator.w3.org/check?uri=http% … 54#line-51

Mike Richards
SimpleViewer Support Team.