Topic: Says "Get Flash"

I installed simpleviewer in PS CS4 successfully. A gallery was created which I can view from my desktop. I then moved the folder to my web site/wordpress folder via the ftp site I use which all went well too. The problem is when I type in the url where the gallery should live it says 'get flash'.

So I clicked on get flash even though I was pretty sure we already had an updated version, downloaded it and still getting same message to 'get glash'.

Is there something I'm doing wrong? Any ideas how to make this work?

Thank you.

Re: Says "Get Flash"

Just FYI
my flash player is current
the swfobject.js file is in the folder
java is enabled
Pretty sure the simpleviewer is new version since I installed it today.
Tried Firefox, tried IE and neither work. Cleared the cache...nada

The viewer should be here:
www.kristiwrightphotography.com/LRgallery/LAB_web


Spoke with my hosting company. They said:
9:23:14 PM]:  http://www.kristiwrightphotography.com/ … viewer.swf - this is interesting
[9:23:20 PM]: a direct link to the flash file works
[9:23:28 PM]: So, there must be something about the index.html file

The link with the viewer.swf does come up however, the background colors are not the ones I chose. I realize this is a minor problem in the grand scheme of things.

I could really use some assistance.
Thank you.

Last edited by kristiwright (2009-08-05 03:36:07)

Re: Says "Get Flash"

Your index page has no line breaks and JavaScript doesn't seem to like this!
Here's a modified version of your index.html page.
http://www.box.net/shared/auaehdyqju
All I've done is use carriage return & line feed to break up the code, indented it for easier reading and put a DOCTYPE declaration (XHTML 1.0 Transitional) at the top of the document.
It should now work.

Last edited by Steven Speirs (2009-08-05 14:08:35)

Steven Speirs
SimpleViewer Support Team.

Re: Says "Get Flash"

Thank you so much. That worked. I wish I understood what you did to the index file and how you did it. Could you explain what you did in detail? How did you even get inside the index.html file? Sorry - total novice here. I tried opening it with a text editor and all I see is the same "get flash" message.

This is obviously something I'll have to do each time I create a gallery. Kind of a pain. Why isn't there a fix for this? It seems many people have the same issue.

Again, thank you for helping me.

Kristi

Last edited by kristiwright (2009-08-05 20:47:35)

Re: Says "Get Flash"

I use Firefox so the following will differ slightly for other browsers.
I typed the address into the Firefox address bar, www.kristiwrightphotography.com/LRgallery/LAB_web
Then, from the 'File' drop down menu, I selected 'Save Page As...' making sure to change the type to 'Web Page, HTML Only'.
I then opened the saved web page in a text editor (Windows Notepad), visually looked for where the line endings should be, put the cursor there and hit 'Return' on the keyboard (many times!).
I could have copied and pasted the entire page into an online formatter but it was a small page so it only took a minute or so to do it manually.
Having noticed there was no DOCTYPE declaration, I inserted one at the beginning (appropriate to the code in the page).
I then checked that the page validated OK by running it through the W3C validator at http://validator.w3.org/ to make sure there were no errors in the code.

Steven Speirs
SimpleViewer Support Team.

Re: Says "Get Flash"

You rock!

I actually just switched out the index.html file that you gave me into the gallery I've been trying to post AS WELL AS another test one I built after the first one failed. Both galleries were viewable. I plan on saving the file and just switching each time I create a new one.

Thanks a million.

Re: Says "Get Flash"

You're welcome!

Steven Speirs
SimpleViewer Support Team.

Re: Says "Get Flash"

i am feeling really dense this am - i saw simpleviewer on a website - thought it was cool, downloaded the simpleviewer regular version with the idea i would play with it before buying the pro because i'd like music with the show - but now when i create a simple test version and uploaded it i get

"needs flash"

this test html will not run on my local machine or on my server

www.tsdconsulting.ca/testviewer 2.html

can anyone help please

thanks
tom

Re: Says "Get Flash"

plz check the FAQ, Q1: http://www.simpleviewer.net/simpleviewer/faq.html

Felix Turner
SimpleViewer Support Team.

Re: Says "Get Flash"

thanks, i needed the main launch page inside the same folder

t

Re: Says "Get Flash"

monkeyboy wrote:

Your index page has no line breaks and JavaScript doesn't seem to like this!
Here's a modified version of your index.html page.
http://www.box.net/shared/auaehdyqju
All I've done is use carriage return & line feed to break up the code, indented it for easier reading and put a DOCTYPE declaration (XHTML 1.0 Transitional) at the top of the document.
It should now work.

I have the same problem as well. The document you posted on Box.net has been removed already. Can you post it again? The page I am trying to upload the flash to is here: http://www.daphnechenphotography.com/we … urces.html
I already have flash player, but it askes me to get flash. Your help is highly appreciated!

Daphne
http://www.daphnechenphotography.com

Re: Says "Get Flash"

The file I originally uploaded was specific to another user's web site and, as such, I deleted the file once I knew the person who needed it had downloaded it.

Your http://www.daphnechenphotography.com/we … urces.html page has the line:

<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>

... but the file http://www.daphnechenphotography.com/Sc … odified.js does not seem to exist on the server.

Steven Speirs
SimpleViewer Support Team.

Re: Says "Get Flash"

monkeyboy wrote:

... but the file http://www.daphnechenphotography.com/Sc … odified.js does not seem to exist on the server.

Thanks for your help. I have added the missing line you suggested. As for the missing url, I am not sure where I am suppose to find that. I just know I have saved the simpleviewer web document in the folder where I keep all my other web pages. Is there something missing? 

I just uploaded the script folder as well. I hope that works.