1

Topic: auto start help

I have tried time and time again to get my autostart function to work and it just will not work? Is it because I'm publishing through Flash CS3? ANy help would be greatly appreciated!

Thanks -

Re: auto start help

Hi,

Flash CS3 is fine for this. 1st make sure that when you republish the viewer.swf file that will be located in the "web" folder in the Pro version of SV, and replace that with the one in your gallery. Also the code to get the auto play to start which is found in the options.as on lines 55 and 56 in the source folder should look like this:

static var enablePlayButton:Boolean = true; //Whether to show play button for autoplay mode.
static var playAtStart:Boolean = true; //Whether to automatically start playing.

Hope that helps. All the best

3

Re: auto start help

thanks so much! I tried again and nothing...
here's the test page http://inahmercedes.com/heather/simplev … index.html

and here's my options.as file:

class com.airtightinteractive.apps.viewers.simpleViewer.Options {
       
    function Options(){};
   
    //Autoplay
   
    static var enablePlayButton:Boolean = true; //Whether to show play button for autoplay mode.
    static var playAtStart:Boolean = true; //Whether to automatically start playing.

   
    //General
    static var fixedLayout:Boolean = false; //Whether to used fixed layout of stage elements, or dynamic resizing based on browser window size         
    static var preloadImages:Boolean = true; //Whether to automatically preload images in the background
    static var useSmoothing:Boolean = true;
   
    //Main Image   
    static var enableImageDownScaling:Boolean = true; //Whether images are resized smaller to fit stage (not used if fixedLayout == true)
    static var enableImageButtons:Boolean = true; //Whether to use image navigation buttons (arrow buttons that overlay the main image)
    static var hideImageButtonsOnRollOut:Boolean = true; //Whether to hide the image navigation buttons when the mouse is not rolled over them
    static var imageFadeLength:Number = 5; //Image fade tween length (frames)

    //Thumbnails
    static var thumbnailWidth:Number = 65; //pixels
    static var thumbnailHeight:Number = 65; //pixels   
    static var thumbnailPadding:Number = 14; //space between thumbs (pixels)
    static var showThumbnailVisited:Boolean = true; //Whether to show visited dogear icon
    static var showThumbnailLoadBar:Boolean = true; //Whether to show load bar on image load
    static var thumbnailFrameWidth:Number = 2; //pixels
    static var thumbnailRollOverFrameWidth:Number = 5;     //pixels
    static var thumbnailSelectedFrameOffset:Number = 3; //pixels that thumb frame is offset  when thumb is selected
    static var thumbnailLoadBarHeight:Number = 10; //pixels
    static var thumbnailClickShift:Number = 2;     //distance thumbnail moves on click (pixels)
    static var thumbnailLoadingAlpha:Number = 60; //alpha of thumbnail while image loads (percent)
    static var thumbnailMotionLength:Number = 20; //Thumb paging slide animation tween time (frames)
                               
    //Captions
    static var showCaptions:Boolean = true; //Whether to show Image Captions   
    static var showTitle:Boolean = true; //Whether to show gallery title
    static var showCaptionOnRollover:Boolean = false; //Whether to show the image caption on thumbnail rollover
    static var captionUnderThumbs:Boolean = true; //Whether to show the captions under the thumbnails or the main image
    static var captionFontSize:Number = 13;
    static var titleFontSize:Number = 16;   
    static var captionPadding:Number = 14; //space between image and caption. Used if 'captionUnderThumbs' is false
                       
    //////////////////////
    //Colors (OPTIONAL)
    //If these are not set, color are loaded from XML options
    //Color values are hex-numbers like this: 0xFF00FF
    static var imageFrameColor:Number = null; //color of main image frame and image nav buttons (overrides XML 'frameColor' value)
    static var thumbnailFrameColor:Number = null; //color of thumbnail frames    (overrides XML 'frameColor' value)
    static var pagingArrowsColor:Number = null; //color of thumbnail paging arrows (overrides XML 'frameColor' value)
    static var captionTextColor:Number = null; //color of captions text (overrides XML 'textColor' value)
    static var titleTextColor:Number = null; //color of title text (overrides XML 'textColor' value)
    ///////////////////////   
   
    ////////////////////////
    //Fixed Layout Positions (OPTIONAL)
    //These options are only used if fixedLayout is set to true
    //ThumbArea width and Height are determined by columns, rows, thumbnailWidth, thumbnailHeight and thumbnailPadding
    static var imageAreaX:Number = 10; //X posn of Image Area
    static var imageAreaY:Number = 10; //Y posn of Image Area
    static var imageAreaWidth:Number = 480; //width of Image Area
    static var imageAreaHeight:Number = 480; //height of Image Area   
    static var thumbAreaX:Number = 500; //X posn of Thumb Area
    static var thumbAreaY:Number = 10; //Y posn of Thumb Area        
    static var backThumbArrowX:Number = 0; //X posn of Back Thumb Arrow (relative to top left of Thumb Area)
    static var backThumbArrowY:Number = 350; //Y posn of Back Thumb Arrow (relative to top left of Thumb Area)
    static var nextThumbArrowX:Number = 200; //X posn of Next Thumb Arrow (relative to top left of Thumb Area)
    static var nextThumbArrowY:Number = 350; //Y posn of Next Thumb Arrow (relative to top left of Thumb Area)   
    static var titleX:Number = 10; //X posn of Title text
    static var titleY:Number = 500; //Y posn of Title text
    static var titleWidth:Number = 480; //width of Title text
    static var titleHeight:Number = 20; //height of Title text       
    static var captionX:Number = 10; //X posn of Title text
    static var captionY:Number = 520; ///Y posn of Title text
    static var captionWidth:Number = 480; //width of Title text
    static var captionHeight:Number = 50; //height of Title text   
    static var downLoadLinkX:Number = 600; //X posn of download link
    static var downloadLinkY:Number = 600; //Y posn of download link
    //////////////////////
   
    //////////////////////
    //XML options overrides (OPTIONAL)
    //Setting these values will replace the values loaded from the XML doc
    static var maxImageWidth:Number = null;
    static var maxImageHeight:Number = null;
    static var frameWidth:Number = null;
    static var stagePadding:Number = null;
    static var navPadding:Number = null;
    static var thumbnailColumns:Number = null;
    static var thumbnailRows:Number = null;
    static var navPosition:String = null; 
    static var vAlign:String = null;
    static var hAlign:String = null;   
    static var title:String = null;
    static var enableRightClickOpen:Boolean = null;
    static var backgroundImagePath:String = null;    
    static var imagePath:String = null; 
    static var thumbPath:String = null;   
    //////////////////////
   

                   
}

4

Re: auto start help

Please!!!! I need help!!!!

Re: auto start help

If you run the fla in falsh (Ctrl Enter) does it auto play?

In the Format tab under Publish Setting what folder is the viewer.swf being published to? Make sure you are using the newly published swf.

Mike Richards
SimpleViewer Support Team.

6

Re: auto start help

Just to make sure I'm doing everything correct. I've edited the options.as file in dreamweaver and then resaved it to the original location. Then I open the flash (it does not autoPlay when I publish preview) then I republish the swf to the web folder and upload the swf to the server and nothing??? Is there a way to just get the autoPlay swf from any where??? I'm desperate to solve this issue smile
thanks so much for your help!!!

Re: auto start help

Ahh... You need to use Flash Pro to republish

Mike Richards
SimpleViewer Support Team.

8

Re: auto start help

So flash CS3 is the problem....?

Re: auto start help

No CS3 should work, sorry your description did sound like your weren't using Flash. When you open the FLA in flash and under the Control menu choose Test Movie (Ctrl Enter on a PC) what happens?

Mike Richards
SimpleViewer Support Team.

Re: auto start help

ii wrote:

Then I open the flash (it does not autoPlay when I publish preview) then I republish the swf to the web folder and upload the swf to the server and nothing??? Is there a way to just get the autoPlay swf from any where?

Also check in Flash CS3 under publish settings and on the format settings window where is the .swf file out put to? It should be to the web folder in SV Pro if its not then tell flash to put it there. If it is in that folder go to it and open the .html page in the folder it should auto play. I have flash cs3 and it works.

11

Re: auto start help

lemme get a PC, I'm using MacOSX, I'm gonna try it right now and I'll post a reply shortly! thanks again for the help... I really really appreciate it!

Re: auto start help

I'm using MacOSX also so I can point you in the right direction.

13

Re: auto start help

Nothing?? It doesn't work on PC platform either??? I don't understand??? I've tried it all I think?

Re: auto start help

Where is the new republished viewer.swf file located? Is it in the web folder in SV Pro?

15

Re: auto start help

am I suppose to change any code anywhere else? As of right now I have just added this to the options.as:


    //Autoplay
   
    static var enablePlayButton:Boolean = true; //Whether to show play button for autoplay mode.
    static var playAtStart:Boolean = true; //Whether to automatically start playing.
    static var displayTime:Number = 5; //Whether to automatically start playing.

Then I open the fla file and republish (using CS3 proffessional) to overide the swf in the web folder.

Then I upload everythinga again to my server.

I have nor changed anything in the index.html (as I don't think I have to?)

??? Thanks -- Inah

16

Re: auto start help

racerx wrote:

Where is the new republished viewer.swf file located? Is it in the web folder in SV Pro?

It is publishing to mysite:heather:simpleviewer_Pro:web:viewer.swf
(but when I attempt to publish preview right of of Flash CS3 pro, the change does not take effect either???)

Re: auto start help

Try this on your original download without any other changes you have made.

In the Simpleviewer Pro folder you downloaded find the FLA in simpleviewer-pro\simpleviewer_pro\source and Options.as in simpleviewer-pro\simpleviewer_pro\source\com\airtightinteractive\apps\viewers\simpleViewer.

Open Options.as in a text viewer in Notepad/TextEdit change both enablePlayButton and playAtStart to true.

static var enablePlayButton:Boolean = true; //Whether to show play button for autoplay mode.
static var playAtStart:Boolean = true; //Whether to automatically start playing.

Save and close Options.as.

Open simpleviewer.fla in flash choose in the File Menu choose Export>Export Movie

Choose the simpleviewer-pro\simpleviewer_pro\web folder

Save as viewer.swf

It should now auto run after a 5 sec pause on the first image. If you continue to have issues try re-downloading the simpleviewerpro.zip file.

Mike Richards
SimpleViewer Support Team.

Re: auto start help

Your correct you do not need to change anything in the html page. After you republished the .swf go to "Test Movie" in flash cs3 (on Mac its under control in the menu bar) does it auto-play? Do not upload to the server until it plays in the "Test Movie". I don't think it makes a difference but try moving your simpleviewer_pro folder outside of your dreamweaver mysite folder. Also before republishing the "new" .swf file take out the old one just in-case it has some how gotten corrupted then republish and go to "Test Movie".

19

Re: auto start help

nope, nothing... The flash file does not appear to be affected by the options.as file? I purchased sv pro going on a couple years ago. Is there still a way for me to redownload the zip? If not and I have to repurchase, and it still doesn't work, then what happens???

Re: auto start help

No you will not have to buy SV Pro again. Go here  http://www.simpleviewer.net/simpleviewe … _form.html and fill out the form and you will be sent a download link via email.

One other thing I assume that the folder lay out is simpleviewer_pro in that folder you have the source folder and the web folder. In the source folder you should have the following simpleviewer.fla and a com folder where the options.as file is located. Another assumption are you republishing using the simpleviewer.fla in the source folder. I know those seem like silly questions but I think the only real silly question is the one that is not asked.

Other than that I would say fill out the form and get the download link.

Last edited by racerx (2009-09-03 23:27:05)

Re: auto start help

I purchased sv pro going on a couple years ago.

AutoPlay was added in v1.9 on 09/12/08 so presumably you are using an older version of SimpleViewer-Pro.

You can use your original download link (sent by email) to get the latest version. If you cannot locate your original download link, please fill out this form to receive a new link: http://www.simpleviewer.net/simpleviewe … _form.html

Felix Turner
SimpleViewer Support Team.

22

Re: auto start help

I tried! I had purchased a couple years ago. I don't have customer ID number anymore, but I do have access to the original email I used to purchase??? don't think that helps much though!  thanks a bunch -- now it makes sense! I spent two days straight doing the changes over and over... and nothing... but what you said would make sense smile