Topic: Problem creating new gallery. Please help!

I've got svManager Pro installed on my web server. I've done the test and everything seems fine, although later on I had to change the permissions for all folders and files to 0777.

However, when I try to create new galleries for the SimpleViewer Pro, it wouldn't allow me - there is a message saying "Error unable to create directory g3 (gallery.php, line 858)"

Can you please help me out as my client is losing patience?

Thanks a lot,

J

Last edited by jmilev (2009-09-18 04:42:52)

Re: Problem creating new gallery. Please help!

Also, in the Customize menu (where I set the colours, frame, etc.), there is this message that appears in red above the menu: "Notice: unable to create thumbnail cache for index page"

Re: Problem creating new gallery. Please help!

It does look like a permissions error so can we please double-check all the basics first.

Is this a Unix/Linux server or Windows?

The server compatibility test reported that safe mode was OFF – yes?

You said that you'd changed all the permissions to 0777 but could you please double-check the following folders and files:
- the svmanager folder itself
- the svmanager/data folder
- all the files inside the svmanager/data folder (please check them individually)

jack

Jack Hardie
SimpleViewer Support Team.

Re: Problem creating new gallery. Please help!

Thanks for the feedback, Jack.

I don't know if it's Unix or Windows server; I am about to find out later today.

The Safe Mode is OFF. When I changed the permissions to 0777, I made sure that change was applied to all the folder and files. I will, however, check them all individually, and will post a reply.

Cheers,

J

Re: Problem creating new gallery. Please help!

Hi Jack,

The web server I am using is Unix/Linux. I've changed the permissions to 0777, and it allowed me to create new galleries. However, this time it wouldn't allow me to upload images. It says "Error occurred. Statuscode 404".

What do I do now???

Re: Problem creating new gallery. Please help!

Also, the webserver doesn't allow me to change permissions to 0777 on G3, G4, G5 (the galleries) folders and the files inside, as well as the GALLERYDATA.TXT file in DATA folder.

Something wrong with the server?

Re: Problem creating new gallery. Please help!

Well the server is probably not wrong. It's just that there are so so many ways of setting up a server and some of them are...how shall I put it...unhelpful wink

The error message is a file not found error. The file could have gone missing but I think it's more likely that the server can't find it because we still have a permissions problem.

Did the file upload work when you ran the server compatibility test?

Would it be possible to do a clean installation of svManager on your server from scratch. Either to replace the existing one or if you don't want to do that then in another directory like svmanager2 or something. You could set the permissions (carefully!) on this second installation, create just one gallery and try an upload. The reason I'm suggesting this is to remove any knock-on effects from the problems you had earlier.

There's some other stuff you can try but I think it's best to go step-by-step or we'll both get confused.

jack

Jack Hardie
SimpleViewer Support Team.

Re: Problem creating new gallery. Please help!

It's working!

Thank you very, very much!

J