Topic: Ok this is weird and strange...

Hi all,

OK I wanted to make a quick gallery (in SV-Pro 1.8 and v1.9) to show some stuff to a client. I opened photoshop CS3 created the new gallery, but at the end when the .html file opens in the browser the gallery doesn't show up at all (in FF and Safari). The last time I did this a few weeks ago everything worked great. The only way I was able to get the gallery to show was to create a .html file in dreamweaver which worked fine. I just do not understand why all of a sudden the generated html does not work. How ever I did place this html file in the /web folder and it worked fine there. I have the gallery.xml, images and thumb folders, viewer.swf and html file all in the same folder. Does anyone have any ideas as to what is going on? Thanks for any help.

Link to test

Here is the complete html code that SV-Pro generated

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "[url][/url]">
<!-- saved from url=(0014)about:internet -->
<html xmlns="" xml:lang="en" lang="en">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<!-- Download SimpleViewer at [url=][/url] -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;

    #flashcontent {
        height: 100%;
    /* end hide */

    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #000000;
    <div id="flashcontent">SimpleViewer requires Macromedia Flash. <a href="">Get Macromedia Flash.</a> If you have Flash installed, <a href="index.html?detectflash=false">click to view gallery</a>.</div>
    <script type="text/javascript">
        var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "7", "#000000");
        fo.addVariable("preloaderColor", "0xffffff");
        fo.addVariable("xmlDataPath", "gallery.xml");

Last edited by racerx (2009-09-28 22:39:54)

Re: Ok this is weird and strange...

Is the 'swfobject.js' file in the generated gallery folder?

Felix Turner
SimpleViewer Support Team.

Re: Ok this is weird and strange...

Hi all,

Well this was an operator (me) error roll. I had updated to the photoshop cs3 script, but the only thing I changed was the swfobject.js because of changes I made in the SimpleViewer.jsx. Since the new one is named ~swfobject.js the SimpleViewer.jsx did not recognize it of course. I have made the the necessary changes to SimpleViewer.jsx and all work great. UGH the more you think you know the less you actually know. smile

Thanks for the help and for a VERY nice product..