Topic: Two Problems with FlickrViewer and SimpleViewer

I posted this in the SoundForge fourms and recieved no help what-so-ever. I know that this problem mainly lies in the XML for FlickrViewer and not SimpleViewer but this is the only other place w3here I know to ask. Im hoping that SOMEBODY, ANYBODY can help me with this..

2009-09-29 18:40:36 UTC
Hi. I am using SimpleViewer and Flickrviewer. I just got my site online today after a few problems with TiltViewer that were left unanswered. for reference - http://samcassidyphotography.com/Gallery.html

The first problem is, I need the image link

 $showImageLink = true; 

to open in a separate window when clicked. This is because I have embedded a iFrame into the HTML code of the page, the iFrame is titled Content and I have all of my links currently loading in this frame. I can usually just check the links in site map and redirect a specific link to open in a different target, however, links within the php and xml codes for Flickr / Tilt viewer are not displayed and I do not know how to alter this code.

The second problem is fitting my descriptions under the thumbnails. I have added the code and updated the PHP so that the description from Flickr is now displayed under the thumbnails, however, as you can see, some of the captions do not fit. I would PREFER to not have to add in any vertical scroll bars or anything else that would complicate viewing images, I mean, after all, its simple viewer, its supposed to be easy big_smile Some options I have thought about are, moving the thumbnails up, reducing the number of rows ( I dont want to do this ), or possibly having a window pop up from the View Full Size link that contains the full scale image and a back button, or maybe the window closes on mouse click, I really have no idea. Any help is appreciated.

I am merely a good novice at working through code... Much thanks in advance !!! -SC

Re: Two Problems with FlickrViewer and SimpleViewer

I have never used FlickrViewer and it looks like it is no longer in development. There is a post on the authors blog stating that the last version of SimpleViewer it was know to work with was 1.7 and the current version is 1.9. This means you may run in to some compatibility issues.

Have you tried adding target="_blank" to line 286 of FlickrViewer?

$xmlout .= "<![CDATA[<a href=\"{$photo[2]}\" target\"_blank\">{$photo[1]}<br /><u>View full size...</u></a>]]>";

As far as fiting in the description/captions you could increase the stage size or use fixedlayout to move the captions or try adding a <font size="12" > </font> to the captions to controll their size.

Mike Richards
SimpleViewer Support Team.

Re: Two Problems with FlickrViewer and SimpleViewer

miker wrote:

I have never used FlickrViewer and it looks like it is no longer in development. There is a post on the authors blog stating that the last version of SimpleViewer it was know to work with was 1.7 and the current version is 1.9. This means you may run in to some compatibility issues.

Have you tried adding target="_blank" to line 286 of FlickrViewer?

$xmlout .= "<![CDATA[<a href=\"{$photo[2]}\" target\"_blank\">{$photo[1]}<br /><u>View full size...</u></a>]]>";

As far as fiting in the description/captions you could increase the stage size or use fixedlayout to move the captions or try adding a <font size="12" > </font> to the captions to controll their size.

Hey Mike, thanks for the reply.. .I added in that line of code @ 286 in the FlickrViewer.php file, reput everything, no luck. The link still opens up in the same frame. Its frustrating me to no end.

As far as the descriptions go, I have solved my problem simply by shortening my descriptions to fit big_smile I will try the HTML within my Flickr page if i ever have a need to. Thanks again.

Re: Two Problems with FlickrViewer and SimpleViewer

wait, would it be possible to just put a HREF code in my description in Flickr that links to the full size and then disable the link to the full size image ? I didn't even think of that..