Topic: Loading flash_embed.swf

I have a as3 site that loaded everything though XML, trying to get Tilt Viewer pro loaded in but can't seem to do so, i'm loading the file flash_embed.swf provided but i'm getting this error

TypeError: Error #1009: Cannot access a property or method of a null object reference.
    at flash_embed_fla::MainTimeline/setOptions()

I need help with this please.

Re: Loading flash_embed.swf

Hi,

don't load the 'flash_embed.swf', load the TiltViewer.swf. 'flash_embed.fla' is an example showing how to load TiltViewer. Open it Flash IDE to see the code.

Felix Turner
SimpleViewer Support Team.

Re: Loading flash_embed.swf

Loading tiltviewer directly does not work, theres no place for me to insert all the option code without that middle embed file

Re: Loading flash_embed.swf

Loading tiltviewer directly does not work

why not? Did you try running the flash_embed example?

Felix Turner
SimpleViewer Support Team.

Re: Loading flash_embed.swf

Because I am adding this to a SECTION of my website I don't want it to just pop up right away, and the way the site is structured all the actions reside in a separate AS file not in the main timeline (like the example file) and all my sections are called through a XML file (not like the example file)  so there is no place to insert that timeline code like the example file has it set up.

Re: Loading flash_embed.swf

It should be fairly straight forward to copy and paste that code into any actionscript file.

Felix Turner
SimpleViewer Support Team.

Re: Loading flash_embed.swf

It's not.  Since your example does not have it in a AS file and I tried and it's just not working, what kind of support can you offer for this implementation?

Re: Loading flash_embed.swf

what errors are you seeing?

Felix Turner
SimpleViewer Support Team.

Re: Loading flash_embed.swf

TiltViewer is still not responding or loading while being loaded under the hood of this framework.  It seems like it's got to do with scope -- it's loading the movie into some sub-scope, and that is probably freaking out TiltViewer. 

I get the error I specified in my first post above, although i'm able to get rid of the error by changing the options code to this, but I get the same results, no tilt viewer. sad

ldr.contentLoaderInfo.addEventListener(Event.INIT, setOptions);
function setOptions(e:Event){
  var options:Object = Object(ldr.content).embedOptions;
  if (options == null){
    options = {};
    Object(ldr.content).embedOptions = options;
  }
  //Set example options here
  options.columns = 3;
  options.rows = 2;
  options.useReloadButton = false;
  options.bkgndTransparent = true;
  options.useFlickr = false;
  options.xmlURL = "gallery.xml";
  options.maxJPGSize = 640;
  options.bkgndTransparent = true;
}

Re: Loading flash_embed.swf

Some time back I was facing similar problem and got fixed at that time. Once again I was trying to do the same thing but fail to remember how did I fix it.

I am trying to load  everything though XML, trying to get Tilt Viewer pro loaded.
I'm loading the file flash_my.swf and getting this error

TypeError: Error #1008: Cannot access a property or method of a null object reference.

Nybody has idea to remove this error??