Topic: Problems with multiple galleries : (

I use the standard SimpleViewer and I very much need help with getting multiple galleries on my webpage.  I believe the problem lies in an incorrect path.
 
One gallery is working fine because it is in the same folder as the page it appears on.  I created a folder called “photoediting” for the second gallery and left the name of the SWFobject, viewer, and xml file unchanged.  In the script, I was careful to change the path of the SWFobject to come from the photoediting folder.  But the second gallery is just showing a duplicate of my first gallery. : (

url= www.rachelraynes.com

1st gallery= “gallery” page
2nd gallery=”photoediting” page

Please help.  Also, before answering my question, keep in mind that I taught myself all this stuff with dreamweaver like 2 weeks ago.  Definitely a newbie.

Re: Problems with multiple galleries : (

Okay, now the second gallery isn't showing up at all...

Re: Problems with multiple galleries : (

In your photoediting.html chage:

<script type="text/javascript">
var fo = new SWFObject("viewer.swf", "viewer", "800", "600", "8", "#FFFFFF");
fo.write("flashcontent");
</script>

to:

<script type="text/javascript">
var fo = new SWFObject("photoediting/viewer.swf", "viewer", "800", "600", "8", "#FFFFFF");
fo.addVariable("xmlDataPath", "photoediting/gallery.xml");
fo.write("flashcontent");
</script>
Mike Richards
SimpleViewer Support Team.

Re: Problems with multiple galleries : (

Thanks for the quick response, Mike.  I tried that and now it seems to be displaying the correct viewer, but the images are not showing up.  My code for the gallery.xml file is as follows:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewergallery maxImageWidth="480" maxImageHeight="480" textColor="333333" 
frameColor="0xFFFFFF" frameWidth="20" stagePadding="40" navPadding="40" 
thumbnailColumns="2" thumbnailRows="6" navPosition="left" vAlign="center" 
hAlign="center" title="Before & After" enableRightClickOpen="false" 
backgroundImagePath="" imagePath="/photoediting/images" thumbPath="/photoediting/thumbs">

Any ideas?

Re: Problems with multiple galleries : (

Change your paths in your gallery.xml from "/photoediting/images" to '''.

Mike Richards
SimpleViewer Support Team.

Re: Problems with multiple galleries : (

That didn't seem to work either.  I've double checked everything.  Not sure what else there is to change.

Re: Problems with multiple galleries : (

It worked!  You're awesome!  Thank you!