Topic: Can't embed gallery to site

Hi,

The problem I have has happened to many people in this forum but I cannot
for the life of me solve it with the advice already given so please excuse this new thread.

I have created a gallery with Pro and copied all the files into a folder in my website.
When I try to open the created page with  Expression Web 3 it shows 'SimpleViewer
requires JavaScript and the Flash Player. Get Fash'  Here is the code:

<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>SimpleViewer</title>
<!-- Download SimpleViewer at www.airtightinteractive.com/simpleviewer -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }

    #flashcontent {
        height: 100%;
    }
    /* end hide */

    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #181818;
        color:#ffffff;
        font-family:sans-serif;
        font-size:20;
    }

    a {    
        color:#cccccc;
    }
</style>
</head>
<body>
    <div id="flashcontent">SimpleViewer requires JavaScript and the Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
    <script type="text/javascript">

        var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "8", "#181818");

        // SIMPLEVIEWER CONFIGURATION OPTIONS
        // To use an option, uncomment it by removing the "//" at the start of the line
        // For a description of config options, go to:
        // http://www.airtightinteractive.com/simpleviewer/options.html

        //fo.addVariable("xmlDataPath", "gallery.xml");
        //fo.addVariable("firstImageIndex", "5");
        //fo.addVariable("langOpenImage", "Open Image in New Window");
        //fo.addVariable("langAbout", "About");
        //fo.addVariable("preloaderColor", "0xFFFFFF");

        fo.write("flashcontent");
    </script>
</body>
</html>

Does anybody what I'm doing wrong?  I have both Flash Player and Javascript
installed on my computer.

Thanking you in advance.

Re: Can't embed gallery to site

please post your url.

Mike Richards
SimpleViewer Support Team.

Re: Can't embed gallery to site

Thanks Miker.  Will do tomorrow as I'm designing website on another computer.

Re: Can't embed gallery to site

miker wrote:

please post your url.


http://remyhunter.co.uk/index%20(2).html

Re: Can't embed gallery to site

where are the  swfobject.js, viewer.swf, and gallery.xml files located? the way your index(2).html is setup they should be in the same folder, if that's not were you want them you need to update the following lines to point to them. You might also have to update the image and thumb paths in the gallery.xml.

<script type="text/javascript" src="swfobject.js"></script>

var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "8", "#181818");

//fo.addVariable("xmlDataPath", "gallery.xml");

Mike Richards
SimpleViewer Support Team.