Topic: Not Showing Gallery

Hi,

I tried to place the flash gallery into my web page but it doesn't seem to show the gallery, except a white box. Here is the web link: http://www.daphnechenphotography.com/we … urces.html

Your help is highly appreciated!

Daphne

Re: Not Showing Gallery

Your gallery HTML page should look something like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>SimpleViewer Gallery</title>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
        <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
        <script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "Simpleviewer/gallery.xml";
            var params = {};            
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "222222";
            swfobject.embedSWF("Simpleviewer/simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>
        
        <style type="text/css" media="screen">    
            html, body    { height:100%; }
            body {            
                margin:0;
                padding:0;
                overflow:auto;
                background-color: #222;
                color:#666;
                font-family:sans-serif;
                font-size:20px;        
            }
            a {    
                color:#ff0000;    
            }
        </style>
        
    </head><body><div id="flashContent">SimpleViewer requires JavaScript and the Flash Player. <a href="http://get.adobe.com/flashplayer/">Get Flash</a></div></body>
</html>
Mike Richards
SimpleViewer Support Team.

Re: Not Showing Gallery

I tried that and it says, "get flash". I already have flash installed?

Re: Not Showing Gallery

Try replacing your weddingresources.html file with the following one.
http://www.box.net/shared/7svr5hsskb

Steven Speirs
SimpleViewer Support Team.

Re: Not Showing Gallery

Thank you monkeyboy!!! I can finally see the web gallery on the page, except that I cannot see the images. How can I make sure the images are in the gallery?

Re: Not Showing Gallery

The paths to the images in your gallery.xml file are incorrect.
Your images are located in http://www.daphnechenphotography.com/Si … er/images/ but SimpleViewer is looking for them in http://www.daphnechenphotography.com/images/
Either move the images directory back a level of adjust the paths in the XML file to be 'Simpleviewer/images/image_name.jpg' rather than 'images/image_name.jpg'.

Steven Speirs
SimpleViewer Support Team.

Re: Not Showing Gallery

Thanks!

I tried to change all the image links to the following in my gallery.html page.

</image>
<image imageURL="simpleviewer/images/bobo_28.jpg" thumbURL="simpleviewer/thumbs/bobo_28.jpg" linkURL="" linkTarget="" >

I just uploaded it again, but it still doesn't work.

I think we are definitely getting close!

Daphne

Re: Not Showing Gallery

The 'Simpleviewer' folder on your web server has an upper-case 'S' (and a lower-case 'v') and the imageURL and thumbURL entries should reflect this.

Steven Speirs
SimpleViewer Support Team.

Re: Not Showing Gallery

Thank you! I see it now!! This is only a testing page. The actual gallery is suppose to be placed under the "portraits" page. Can I just copy the entire coding in my weddingresources page to the portraits page?

Daphne

Re: Not Showing Gallery

Without knowing the exact structure of your web site that you are aiming for, I can't be sure.
Is the single SimpleViewer gallery to replace all three galleries in individual subfolders that the present 'Portraits' page links to?  If so, then you could simply rename weddingresources.html to portrait.html as they are both located in the same folder on the server.
Whatever, you do, just make sure that all links within the HTML file have the correct paths in order to point to the files in question correctly (ie your style.css file, swfobject.js, simpleviewer.swf and gallery.xml).

Steven Speirs
SimpleViewer Support Team.

Re: Not Showing Gallery

Yes, I would like to use this single gallery to replace all three galleries in Portraits. Therefore, I will just rename Wedding Resources to Portraits to replace it. I would like to change the background colour of the gallery to black. Do you know where can I change it?

I would like to create a gallery for "engagements", "Weddings" and "Events". Can I just copy the entire coding of Wedding Resources and only change the link here: flashvars.galleryURL = "Simpleviewer/gallery.xml"? Maybe have another folder xml file under simpleviewer called "engagements.xml"?

BTW, thank you so much for your help. Without you, I wouldn't be able to set up my first simpleviewer gallery!

Daphne

Re: Not Showing Gallery

To change the background color to black, use the following line in your HTML page:

params.bgcolor="000000";

Yes, you can have several XML pages alongside each other for several galleries and refer to them individually using flashvars.galleryURL="gallery1.xml", flashvars.galleryURL="gallery2.xml", etc.
As long as the links to the images in the XML files are correct, your galleries should work fine.

Steven Speirs
SimpleViewer Support Team.

Re: Not Showing Gallery

Thank you so much!!

The black background worked! I did a photo shoot yesterday and have been really busy editing the photos. I will add the simpleviewer gallery to all my pages when I have a chance. I think I know how to do it now. Thank you so much for your help once again! I really appreciate your help!

Have a good day!
Daphne