Topic: Simpleview 2 in FireFox

PLEASE help!  I upgraded to v2 to try to solve my FF problem.  I took the web/index.html and gallery.xml files (located in App_Scripts/simpleview) and adjusted for my desired xml paths.  Works still in IE but not in FF!  What am I doing wrong?  I have the correct Flash version installed.  The host server does not block, as some posts have indicated could be problematic.  Following please see the adjusted index.html and gallery.xml.  I also find that I changed the galleryStyle to COMPACT but it is not displaying in either browser in that format.  URL is https://www.firstresource.us/app_script … index.html.

Thank you in advance, I am desperate here...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>SimpleViewer Gallery</title>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
        <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
        <script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "../../../Images/HomeImages/44/XML/gallery.xml";
            var params = {};           
            params.allowfullscreen = true;
            params.allowscriptaccess = "always";
            params.bgcolor = "222222";
            swfobject.embedSWF("simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
        </script>
       
        <style type="text/css" media="screen">   
            html, body    { height:100%; }
            body {           
                margin:0;
                padding:0;
                overflow:auto;
                background-color: #222;
                color:#666;
                font-family:sans-serif;
                font-size:20px;       
            }
            a {   
                color:#ff0000;   
            }
        </style>

       
    </head><body><div id="flashContent">SimpleViewer requires JavaScript and the Flash Player. <a href="http://get.adobe.com/flashplayer/">Get Flash</a></div></body>
</html>

<?xml version="1.0" encoding="UTF-8" ?><simpleviewergallery  galleryStyle="COMPACT" textColor="0x999999" frameColor="0x999999" frameWidth="0" thumbColumns="3" thumbRows="3" showOpenButton="TRUE" showFullscreenButtom="TRUE" maxImageWidth="500" imagePath="\Images\HomeImages\44\" thumbPath="\Images\HomeImages\44\Thumbs\">
<image imageURL="\Images\HomeImages\44\328WoodRdg_front.jpg" thumbURL="\Images\HomeImages\44\Thumbs\328WoodRdg_front.jpg"></image>
<image imageURl="\Images\HomeImages\44\328WoodRdg_LR.jpg" thumbURL="\Images\HomeImages\44\Thumbs\328WoodRdg_LR.jpg"></image>
<image imageURL="\Images\HomeImages\44\328WoodRdg_yard.jpg" thumbURL="\Images\HomeImages\44\Thumbs\328WoodRdg_yard.jpg"></image>
<image imageURL="\Images\HomeImages\44\328WoodRdg_kit.jpg" thumbURL="\Images\HomeImages\44\Thumbs\328WoodRdg_kit.jpg"></image></simpleviewergallery>

Re: Simpleview 2 in FireFox

BTW, before my adjustments the page worked in FF as well as IE...

Re: Simpleview 2 in FireFox

Your XML should look like this:

<simpleviewergallery galleryStyle="COMPACT" textColor="0x999999" frameColor="0x999999" frameWidth="0" thumbColumns="3" thumbRows="3" showOpenButton="TRUE" showFullscreenButtom="TRUE" maxImageWidth="500" imagePath="/Images/HomeImages/44/" thumbPath="/Images/HomeImages/44/Thumbs/">
<image imageURL="328WoodRdg_front.jpg" thumbURL="328WoodRdg_front.jpg"/>
<image imageURl=328WoodRdg_LR.jpg" thumbURL="328WoodRdg_LR.jpg"/>
<image imageURL="328WoodRdg_yard.jpg" thumbURL="328WoodRdg_yard.jpg"/>
<image imageURL="328WoodRdg_kit.jpg" thumbURL="328WoodRdg_kit.jpg"/>
</simpleviewergallery>

Mike Richards
SimpleViewer Support Team.

Re: Simpleview 2 in FireFox

If Miker's suggestion doesnt work try changing height to a set value. I have found in firefox if not a set value for height then it wont show as it thinks its 0px high.

Re: Simpleview 2 in FireFox

imagePath and thumbPath are relative to the HTML page https://www.firstresource.us/app_script … index.html so, in the XML Page https://www.firstresource.us/Images/Hom … allery.xml change:

imagePath="/Images/HomeImages/44/"
thumbPath="/Images/HomeImages/44/Thumbs/"

... to:

imagePath="../../../Images/HomeImages/44/"
thumbPath="../../../Images/HomeImages/44/Thumbs/"
Steven Speirs
SimpleViewer Support Team.

Re: Simpleview 2 in FireFox

Well, since messing with the paths it doesn't work in IE anymore, either... let me get the pathing right and working in IE again...  roll