Topic: Simpleviewer not visible on IE (pc)

Hello,

Im builing a website that contains simpleviewer. It took me a long time to get it exactly how i wanted it but now it is really nice... I loaded it up because I was happy with the result on my Mac. A friend of my told me he couldn't see the simpleviewer on IE on a PC so I checked it... It is not working on IE!

Anybody any idea how to solve this?

The URL is http://www.sweetwheels.nl/zoetigheid.html

Thanks in advance!

Kees

Re: Simpleviewer not visible on IE (pc)

Looking at the source for that page you have two HTML tags, remove one. Additionally your script tag should look like this

<script type="text/javascript" src="js/rollover.js" >

beyond that you can check the W3C Validator for issues here.

Mike Richards
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

Thanks for your help!

I did the things you said; Removed the double <html> tag and replaced the script...

The problem is still the same. I know the code is far from clean so it is hard but any idea to solve the problem of the not vissible swf? In safari and firefox on mac it is visible but on Internet Explorer on a pc i see only a white box (screenshot: http://www.sweetwheels.nl/images/site_image.jpg )

Thanks again!

Re: Simpleviewer not visible on IE (pc)

I've knocked the number of validation errors down from 154 to 8 and changed the embed method from <object><embed> to swfobject v2.2
The following zip file contains the new version of zoetigheid.html and swfobject.js, both of which should be uploaded to the root of your web site.
http://www.box.net/shared/g57kc529h6
I can't be certain that it'll solve your problems but it's a step in the right direction.

Steven Speirs
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

Thanks man!!!

It works now! And a much cleaner code ;-)
Thank you very much!

Cheers!

Re: Simpleviewer not visible on IE (pc)

Hi I have a similar problem and didn't want to make a new thread for it.  I'm pretty html illiterate, but I managed to throw a page together that works fine on Firefox, Safari and Chrome, however the flash is not working with IE.  I tried some of the things mentioned here, and ran it through that validator, but couldn't figure out what was wrong. I'm sure my code is messy and there are similar little mistakes...as I said html is not my specialty. 

www.toddlevinphotography.com

If you guys can take a look I'd really appreciate it, hopefully its just a quick fix.

Last edited by Towdini (2009-12-17 17:20:00)

Re: Simpleviewer not visible on IE (pc)

At the very top of your http://www.prism.gatech.edu/~tlevin3/travel/index.html page, replace:

<html xml:lang="en" lang="en">

... with:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
Steven Speirs
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

monkeyboy wrote:

At the very top of your http://www.prism.gatech.edu/~tlevin3/travel/index.html page, replace:

<html xml:lang="en" lang="en">

... with:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">

Awesome, works great now thanks...never would have figured that out on my own.

Re: Simpleviewer not visible on IE (pc)

I think I may have a different implementation problem than the 2 above. So far, I have been able to make my gallery function just fine in Firfox, Safari, Chrome and IE on only 1 system. I have tried on three other systems, including 1 intel dual boot macbook. All simply load the blank indented white box. No javas errors. Using IE 8 on the system that works.

Any ideas why this may not be running properly in IE on most/all IE instances?

Appreciate any help or suggestions!

http://fcc-online.net/decorative-hw/

Last edited by oakenpalooza (2009-12-27 06:50:47)

Re: Simpleviewer not visible on IE (pc)

works fine here. Are all your machines connected to the web? Did you clear your caches?

Felix Turner
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

Absolutely cleared cache in all instances. I've gone as far as to remove the flash player and reset IE to defaults (thereby promting to reinstall that MSXML plugin in IE).

Another user just posted a separate thread on same subject....may be related?

Re: Simpleviewer not visible on IE (pc)

1) AC_AX_RunContent is bad.

2) IE can have issues with the <object> tag.

3) you are using both  AC_AX_RunContent and embed.
This is your code:
<script type="text/javascript">

AC_AX_RunContent( 'width','100%','height','550','src','simpleviewer.swf?galleryURL=gallery.xml','type','application/x-shockwave-flash','allowscriptaccess','always','allowfullscreen','true','bgcolor','f3f3f3','movie','simpleviewer.swf?galleryURL=gallery.xml' ); //end AC code
</script><noscript><object width="100%" height="550">
              <param name="movie" value="simpleviewer.swf?galleryURL=gallery.xml"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><param name="bgcolor" value="f3f3f3"></param><embed src="simpleviewer.swf?galleryURL=gallery.xml" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="100%" height="550" bgcolor="f3f3f3"></embed></object></noscript>

To embed simpleviewer in html please see this page.

Mike Richards
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

Thanks Miker, that did it.

That was the flash compatilbity adjustment that Dreamweaver 8.0.2 insists on implementing to every flash page. I take it this is now an obsolete method. Is there any patch that you know of for this other than to upgrade?

Best Regards, Ben

Re: Simpleviewer not visible on IE (pc)

I'm not sure there is any thing you can change in Dreamweaver just don't use Dreamweaver's Insert -> Media -> SWF method.

Mike Richards
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

Hi Mike,

I seem to be having the same problem and also didn't want to start a new thread. I've tried changing the information in the header and have already used the html embed info (that actually got things working for firefox.

In IE8 the simpleviewer doesn't display. Can you help?

Also, in Chrome, the page is displayed with a large white footer below the bottom of the normal page? Can you see any info for why this is?

Thanks

Nick

The page is www.test.parkershots.com/test.html

Re: Simpleviewer not visible on IE (pc)

Hi, God knows what is happening - probably user error but I tried implementing the above solution earlier and it didn't fix it. Now it does, although now I need to make the simpleviewer transparant again in order to see the submenus above.

I tried adding <param name="wmode" value="opaque">  into the code but this caused the whole simpleviewer to stop working. Please can you tell me where I need to add it and what do I need to add to make simpleviewer transparent or opaque again?

Re: Simpleviewer not visible on IE (pc)

OK. I added "params.wmode = "transparent";" above the swfobject line and it's sorted.

I just need to work out why the spry menu isn't being displayed in the correct location in IE and it's sorted. Any ideas please people?

Re: Simpleviewer not visible on IE (pc)

Changed the DOCTYPE to the following and everything is sorted. Cheers

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Re: Simpleviewer not visible on IE (pc)

Hi Guys,


I'm having kind of the same problem. I build my website on my Mac with Dreamweaver.. simple html pages, and wanted to integrate a simpleviewer gallery in one of them. I uploaded with Filezilla on the FTP.

It's working fine on my mac, even if I go to the internet at the page address, its loading the gallery. But when I try from my work computer or when its other people, it just doesn't load and the page stays empty.

the page where the gallery should appear is http://viperparkingonly.free.fr/site/Portfolio.html


Anyone seeing some errors in the code I need to fix?


Thanks a lot for your help

Re: Simpleviewer not visible on IE (pc)

@ViperGTSeb I would take a look at these HTML errors.

Mike Richards
SimpleViewer Support Team.

Re: Simpleviewer not visible on IE (pc)

I'm really hoping somebody can tell me what I'm doing wrong here.

This seems to work perfectly in all browsers expect IE.

Really simple code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
    <head>
        <title>Liane Roux Photography: Life Gallery</title>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    </head>

<body bgcolor="black">

        <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="686" height="60">
                      <param name="movie" value="flash/menu.swf">
                      <param name="quality" value="high">
                      <embed src="flash/menu.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="686" height="60"></embed>
        </object>


        <object width="100%" height="550">
            <param name="movie" value="flash/simpleviewer.swf?galleryURL=life.xml">
            <param name="allowFullScreen" value="true">
            <param name="allowscriptaccess" value="always">
            <param name="bgcolor" value="000000">
            <embed src="flash/simpleviewer.swf?galleryURL=life.xml" 
                type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="100%" height="550" 
                bgcolor="000000"></embed>
        </object>
</body>
</html>

Now as you can see, I have two separate flash instances on this page.
The top one (Menu.swf) displays perfectly fine but I just have a white block where simpleviewer.swf should be.

I've tried embedding using the javascript option but then I have problems with Firefox whereby it doesn't load.
This just seemed to be the simplest way around it.

Any ideas on what I should change?

To see the page in question, you can go to http://www.lianerouxphotography.co.za/life.html

Re: Simpleviewer not visible on IE (pc)

Okay, I found the problem.
I forgot to define the object class and type for the 2nd one. tongue

Re: Simpleviewer not visible on IE (pc)

Dear firends, i have the same problem for a photogallery located at
http://www.cinealba.it/gallery/index.html
A white box appears on IE, while on Chrome, Safari and Firefox it perfectly works!
Anybody could help me please?

Re: Simpleviewer not visible on IE (pc)

wow! forget it! after a giant headhache it works!

Re: Simpleviewer not visible on IE (pc)

@alekos. You need to replace 'Main.swf' in your embed code with 'simpleviewer.swf'.

Felix Turner
SimpleViewer Support Team.