Topic: Possible to use SWFs with scrambled URLs?

Hello,

is there any way to use SWFs in the slideshows when all file URLs are "scrambled" by a CMS, e.g. when the file path is something like

.../somefunction.asp?FileID=xxxx

?

This works just fine with JPGs, but trying to use SWFs results in the following error:

TypeError: Error #1034: Type Coercion failed: cannot convert flash.display::MovieClip@2eeedaf1 to flash.display.Bitmap.
    at com.airtight.simpleviewer.display.thumbs::Thumb/resizeThumbToFit()
    at com.airtight.simpleviewer.display.thumbs::Thumb/onThumbLoaded()

Any way around this? Have tried using both SWFs and JPGs for the thumb, but the error keeps coming up.

Re: Possible to use SWFs with scrambled URLs?

Hi,

the URL of the image should not cause that error. Using a SWF for a thumbnail may do that. Do you have a URL I can look at?

Felix Turner
SimpleViewer Support Team.

Re: Possible to use SWFs with scrambled URLs?

Thanks for replying!

Sure, take a look at http://aie2.syzweb.no/?CatID=1227

The xml file is here: http://aie2.syzweb.no/admin/common/getI … ileID=1374

Presently the sixth file (the swf, FileID 1375) is set up with a JPG as a thumbnail (FileID 1363), but errors come up even with no thumbnail specified or with a single-frame swf (e.g. FileID 1376).

Seem to remember this worked fine in 1.9, by the way, so if there's no solution, I'll switch back smile

Thanks for developing SimpleViewer!

Re: Possible to use SWFs with scrambled URLs?

In Linux/firefox the sixth thumb shows fine, If I wait for the swf to preload before clicking on the thumb everything works fine, but if I click on the thumb before the preload is finished the preloader seems to get stuck at 100%. If I click away to another thumb and click back it works fine. Do you know if you are using the latest version of SimpleViewer 2, version 2.0.1? There were some fixes to the preloader in this release.

Mike Richards
SimpleViewer Support Team.

Re: Possible to use SWFs with scrambled URLs?

It pays off to test properly before complaining...

Turns out the error didn't appear on Win/Linux for me either, so updating the Flash 10 plug-in on the Mac from r12 to r42 made the error go away.  smile

Only minor issue that remains now (on all browser/platforms for me) is that the preloader freezes at 100% until hovering over / clicking the thumb, but that doesn't really matter.

Thanks for helping!