Topic: /svmanager - 500 Internal Server Error


The other day I started setting up my website with SimpleViewer galleries using svManager. It all worked well to start off with (including uploading photos), however now when I add /svmanager to the end of my domain name I receive the following message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@(domain name) and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I know I must have done something to cause this, however I couldn't figure out what it might have been, so I deleted the svmanager folder from my server and then re-uploaded it. In hindsight this was probably not a smart thing to do  roll  And it seems that way, because I am still receiving the same error.

Any help you can give me would be much appreciated. Is there a way to just start over?


PS. I haven't posted a link to the website as it's a work-in-progress...but let me know if you need to see it. Thanks again.  smile

Re: /svmanager - 500 Internal Server Error

Is there a way to just start over?

If you deleted svManager and uploaded it again then you did start over.

Some servers are set-up deliberately to throw an error if they don't like the permissions on a script or on its parent folder. So maybe you changed the permissions? Or maybe the server people changed their setup? It's worth checking this out first. Check-out the help documentation for your server or ask the server admin/helpdesk what are the recommended permissions for php scripts.

The other useful thing to do is to install the svManager server compatibility test on your server and see if it gives the same problems.


Jack Hardie
SimpleViewer Support Team.

Re: /svmanager - 500 Internal Server Error

Thanks Jack,

It was a problem with the permissions. I recently changed FTP programs and the new one was assigning 777 for permissions when my server doesn't allow anything greater than 755.

I followed the svManager Server Compatibility Test troubleshooting intructions here: … fileerrors
(changing folders to 755 and files to 644).

Everything appears to be running smoothly now.

Thanks again for pointing me in the right direction smile