Topic: blurry images

Hello,

I'm designing a flash website for myself and am just about done. Autoviewer Pro (embedded in flash) looks great but I'm having some issues with image quality. The images appear blurry when I preview then in flash so I know it has nothing to do with inserting the swf into the html. I'm sure it's a simple matter that I'm overlooking and I'd appreciate any help in helping me solve this.

The images have different widths but all have a height of 443px so that they appear aligned without resizing in autoviewer. I've set both the Enable ImageDownScaling and EnableImageUpScaling to false and the stage has a global height (of 443px) and width set in the flash website.

Does anyone have any clue why this is happening? The website is located at www mirnamonla ca. Most of it is up but there are a few empty sections. I've been using portfolio>thesisproposal  to play around with it as the text makes it easy to see the quality difference.

Thank you very much for your help and happy new year to everyone,

Mirna

Re: blurry images

Hello again,

For the past fews days I have tried the following things in the hopes of solving my blurry image problem. None of these have worked unfortunately, does anyone have any other suggestions? The difference in quality is easy to see in the "sketching" section of the website for example if you right click and view any of the images in another window.

- playing with the global stage height and width in my flash (it is currently 443px x 680px)
- adding a MaxImageHeight and width in the xml (my pictures are partly landscape and partly portrait, so none of them have a common  width)
- I've double checked all of my jpegs, they are correctly sized at a height of 443px (same as my movie clip height and stage height) and none of them are saved as progressive
- I've recreated the movie clip button in which the gallery is loaded
- I've republished my source autoviewer and replaced the swf in my local folder.

I'd appreciate any help or suggestions in helping me solve this... it seems like a relatively simple issue but I've seen that others on this forum have had the same problem. I've used the free version of autoviewer for more than a year without any problems, which leads me to think I must have overlooked a setting somewhere.

Thanks again,

Mirna

Re: blurry images

Firstly don't use Adobe's Run Active Content to embed the SWFs, use SWFObject instead. Which browser are you using to view your site?

Mike Richards
SimpleViewer Support Team.

Re: blurry images

Thanks Mike, I've republished my website using SWFObject. I'm on a PC and I've previewed it in firefox, ie (where it doesn't appear to be working at all) and safari, still with the same blurriness problem. It begins appearing when I preview the the website in flash, before I publish it as an swf.

Re: blurry images

I've played around some more with it and it looks like my blurriness problem has to do with inserting the autoviewer swf into my shell swf (the website itself). I'm using the following code to do this, does anyone have any clue why this is causing blurriness?


Stage.align = "TL";
Stage.scaleMode = "noScale";
Stage.addListener(this);

_global.AVStageWidth = 680;
_global.AVStageHeight = 443;

var galleryId:String;
var mLoader_mcl = new MovieClipLoader();
mLoader_mcl.addListener(this);


function loadGallery(galId){
    galleryId = galId
    //set gallery xml path
    _root.xmlURL = "gallery5.xml"
    mLoader_mcl.loadClip("autoviewer.swf",SKETCH);
}

loadGallery("gallery5.xml");

Re: blurry images

I got this concern also, I'll going to follow this..thanks.. smile

Re: blurry images

@mirna_m - have you tried giving your swf a little extra room beyond the max image size? How are you creating the images for your gallery, are you using one of our plugins or something else?

@lhavisleir - please post the URL of the gallery you are having issues with. How are you creating the images for your gallery, are you using one of our plugins or something else?

Mike Richards
SimpleViewer Support Team.

Re: blurry images

Hi Mike,

I've created the images for the gallery one by one using Photoshop. I tried using the Photoshop plugin but since there was no way to set the width, it gave me different results for portrait and landscape pictures. The images look fine when I view them directly from the autoviewer.swf file, but never after I've embedded the swf in my shell swf. I tried playing with different values of the _global.AVStageHeight and height of the movie clip button but all it did was rescale the player with the same quality loss. Is this what you meant by giving the swf more room?

Thanks,

Re: blurry images

SOLVED!!! All I had to do was set the useSmoothing value to false in the Options.as

Thanks for the help!