Topic: Gallery will not function on web

My autoviewer gallery is functioning locally, but does not display when loaded on my web page. The site was built on Dreamweaver and is hosted on GoDaddy. I have already contacted them, and they do not believe it is an issue with the server.

My gallery opens as a pop-up window from my main page. The window opens, but there is nothing inside but a blank white page.

The website is: www.alissaambrose.com, the autoviewer gallery is under the portfolio link.

Please help!

Thank you.

Re: Gallery will not function on web

If you goto http://www.alissaambrose.com/autoviewer/autoviewer.swf nothing comes up are you sure you uploaded the autoviewer.swf? If you did what FTP program did you use?

Mike Richards
SimpleViewer Support Team.

Re: Gallery will not function on web

The whole folder, including the swf file is in there. I use Fetch for the FTP upload.

The "portfolio" link is set to open the autoviewer index page.

Re: Gallery will not function on web

Older versions of Fetch eat SWFs on upload, try deleting the autoviewer.swf on the server, upgrading Fetch or use a different FTP program like Filezilla and then uploading the autoviewer.swf again.

Mike Richards
SimpleViewer Support Team.

Re: Gallery will not function on web

Just re-uploaded on the most recent version of Fetch, still no luck.
Here is the code from the autoviewer index.html. All I can think of is that I messed up something in the code.

<!-- saved from url=(0014)about:internet -->
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<title>Alissa Ambrose Portfolio</title>
<!-- Download AutoViewer at www.airtightinteractive.com/projects/autoviewer -->
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }
    #flashcontent {
        height: 100%;
    }
    /* end hide */
    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #ffffff;
        color:#000000;
        font-family:Helvetica, Arial sans-serif;
        font-size:36;
    }
    a {
        color:#000000;
    }
body,td,th {
    font-family: Helvetica, Arial sans-serif;
    font-size: 36px;
    color: #000000;
}
a:link {
    text-decoration: none;
}
a:visited {
    text-decoration: none;
}
a:hover {
    text-decoration: none;
}
a:active {
    text-decoration: none;
}
.style1 {font-size: 12px}
</style>
</head>
<body>
<div class="style1" id="flashcontent">
      <p align="center">AutoViewer requires JavaScript and the Flash Player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a> </p>

    </div>

<script type="text/javascript">
        var fo = new SWFObject("autoviewer.swf", "autoviewer", "100%", "100%", "8", "#ffffff");

        //Optional Configuration
        fo.addVariable("langOpenImage", "Open Image in New Window");
        //fo.addVariable("langAbout", "About");
        //fo.addVariable("xmlURL", "gallery.xml");

        fo.write("flashcontent");

    </script>
</body>
</html>

Re: Gallery will not function on web

The code looks ok, I would try filzilla if fetch didn't work. All you should have to reupload is the SWF.

Mike Richards
SimpleViewer Support Team.

Re: Gallery will not function on web

I reuploaded using Cyberduck and all is well. Thank you so much for your help! (That is a weird glitch with Fetch)