Topic: viewer in iframe with IE on Windows

Hi,

I am embedding autoviewer pro and simpleviewer pro gallaries via iframe. It works fine on Macs with Safari and Firefox. Unfortunately  on Windows with IE, there is a gap at the top, right and bottom. It looks like the gallery does not have 100% of its size or if it is displaced to the left or something like this.

I use the following iframe code:
<iframe src="http://lindegger.de/kampagne2viewer/index.html" width="960px" height="480px" hspace="0" vspace="0" frameborder="0" scrolling="auto"></iframe>

here is the link to the draft site:
http://www.lindegger.eu/?page_id=87

It would be great if you could help.

Thanks and best regards
Sven

Re: viewer in iframe with IE on Windows

Looks like you have HTML errors in your pages. For example in http://www.kuessdiebraut.de/kollektion/ title=""Spieglein, Spieglein an der Wand""> should be title="&quot;Spieglein, Spieglein an der Wand&quot;">. Please us http://validator.w3.org/ to find and fix these errors.

Mike Richards
SimpleViewer Support Team.

Re: viewer in iframe with IE on Windows

Mike,

many thanks for your reply. I got rid of most of the errors. Unfortunately, the problem is still there and I still have got iframe related errors:

- "Attribute "src" exists, but can not be used for this element." (validator says the same "width", "height" ...)
- plus also an error saying "element "iframe" undefined."

I don´t know what to change. Is there another way to embed the flash galleries?
(I try to embed the viewers in the thesis wordpress theme multimedia box, but had the same problems using iweb html snippets).

any ideas are appreciated, thanks a lot
Sven

Re: viewer in iframe with IE on Windows

Attribute "src" exists, but can not be used for this element." (validator says the same "width", "height" ...)

In an <iframe> tag src, wdth, height etc. are only allowed in Doctype Transitional or Frameset, you are using Strict.

Why are you using iframes? Why not just embed the gallery directly into the page?

You should be able to use the following in place of the iframe in http://www.kuessdiebraut.de/kampagne/kampagne-2/

from:

<iframe src="http://kuessdiebraut.de/wp-content/viewer/kampagne3viewer/index.html" width="960px" height="480px" hspace="0" vspace="0" border="0" frameborder="0" scrolling="auto" allowTransparency="true"></iframe>

to:

In the head of your doc
<script type="text/javascript" src="http://kuessdiebraut.de/wp-content/viewer/kampagne3viewer/swfobject.js"></script>

and in the body

<div id="flashcontent">AutoViewer requires Adobe Flash. <a href="http://www.macromedia.com/go/getflashplayer/">Get Adobe Flash.</a> If you have Flash installed, <a href="index.html?detectflash=false">click to view gallery</a></div>   
    <script type="text/javascript">
        var fo = new SWFObject("http://kuessdiebraut.de/wp-content/viewer/kampagne3viewer/viewer.swf", "viewer", "960px", "480px", "8", "#FFFFFF" );
        fo.addVariable("xmlURL", "http://kuessdiebraut.de/wp-content/view … rydata.xml");
        fo.addParam("scale", "noscale");
        fo.addParam("quality", "best");
        fo.addParam("wmode", "transparent");
        fo.addVariable( "langOpenImage", "Bild in neuem Fenster öffnen" );
        fo.addVariable("langAbout", "Info");
        fo.write("flashcontent");           
    </script>

Mike Richards
SimpleViewer Support Team.

Re: viewer in iframe with IE on Windows

Mike,

thanks again for your input, I really appreciate it.

The template/theme I am using allows me to insert HTML code within form. What I put in there (for example an iframe) shows like this on the final page:

<div id="multimedia_box" class="custom_box">
                <div id="custom_box">
<iframe src="http://kuessdiebraut.de/wp-content/viewer/kampagne2viewer/index.html" width="960px" height="480px" hspace="0" vspace="0" border="0" frameborder="0" scrolling="auto" allowTransparency="true"></iframe>
       </div>

The page itself is generated automatically. Which is a good thing, as I don´t know much about html (you might have guessed that ;-))

However, you brought me to an idea, I changed the index.html within the viewer folder, and edited the 100% values for width and height to 960px and 480px values, and it seems to work correctly now also with IE.

I am sure it still is the wrong way to do it, but I hope it is not too bad ?

Thanks again and best regards
Sven