Topic: Different galleries, but showing same images!?

Hi

I am currently using LR2 to create my simpleviewer (not sure what version) galleries. I have embedded one into my website (www.davelphotography.com.au/leon.html).

I am using Web Creator 4 Pro for all the designing etc. I embedded by copying the contents of the SV folder named (leon) into the web folder that the html is in and then 'inserting a SWF/Flash object' on a WYSIWYG section of Web Creator.

I now want to embed another gallery on a different html page. I have put the contents of this SV folder named (louis) into a sub folder where the html is because I know the files from both SV folders have the same names.

I do the usual thing in Web Creator, add the SWF file from the correct folder (all the paths in the html code relate correctly) but it shows the images from the first gallery I mentioned earlier that I created! (www.davelphotography.com.au/louis.html)

I'd really appreciate some help. I've searched everywhere and can't seem to find anyone with the same problem.

Thanks so much

Re: Different galleries, but showing same images!?

You can use the option xmlDataPath to point to the correct XML file. I would suggest using SWFObject to embed the gallery see the link below.

http://www.simpleviewer.net/simpleviewe … /embedded/

fo.addVariable("xmlDataPath", "theGalleryXML.xml");
http://www.simpleviewer.net/simpleviewer/options.html

Mike Richards
SimpleViewer Support Team.

Re: Different galleries, but showing same images!?

Hi Mike,

So am I still doing what I did with the first gallery in Web Creator 'insert flash object' and then edit the HTML?

Do I change anything in the code that's in the link you mentioned?

<script type="text/javascript" src="swfobject.js"></script>
<div id="flashcontent">SimpleViewer requires JavaScript and the Flash Player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">
var fo = new SWFObject("viewer.swf", "viewer", "800", "600", "8", "#181818");
fo.write("flashcontent");   
</script>

I'm not a pro with this coding stuff... I'm really just into using the WYSIWYG. If you could tell me exactly what to do that would be great.

Do you know what the reason is for it picking up different images when the path look correct?

Thanks so much again

Re: Different galleries, but showing same images!?

Do you know what the reason is for it picking up different images when the path look correct?

By default simpleviewer looks for a XML file called gallery.xml this file tells the gallery what options to use and what images to load. Because your galleries are in the same folder you need to name each gallery.xml uniquely such as leon.xml, louis.xml, etc. However the simpleviewer flash file will not know which XML you want it to load until you tell it and if you don't tell it which one to load will just look for and load the default gallery.xml.

So am I still doing what I did with the first gallery in Web Creator 'insert flash object' and then edit the HTML?

You continue to do it this way you need to add in an xmlDataPath.

For www.davelphotography.com.au/leon.html you are currently using the code below. The bold part is new.

<OBJECT ID="LMFlashFlash1"
classid="CLSID:D27CDB6E-AE6D-11cf-96B8-444553540000"
CODEBASE="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#3,0,0,0"
LEFT=0
TOP=0
WIDTH=727
HEIGHT=541
standby="Loading FLASH Player components...">
<PARAM NAME="SRC" value="./leon.swf">
<PARAM NAME="PLAY" value="true">
<PARAM NAME="LOOP" value="true">
<PARAM NAME="MENU" value="false">
<PARAM NAME="QUALITY" value="High">
<PARAM NAME="SCALE" value="NoBorder">
<PARAM NAME="WMODE" value="Transparent">
<Embed type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/shockwave/download/"
src="./leon.swf"
Name="LMFlashFlash1"
LEFT=0
TOP=0
WIDTH=727
HEIGHT=541
QUALITY=High
SCALE=NoBorder
WMODE=Transparent
xmlDataPath="leon.xml"
PLAY=True
LOOP=True
MENU=False >
</embed>
</OBJECT>

Then rename http://www.davelphotography.com.au/gallery.xml to leon.xml and do the same for the rest of your galleries.

If you want to use swfobject it would replace the code above, but if what you have is working stick with that for now.

Mike Richards
SimpleViewer Support Team.