Topic: Same problem as others before... it does not work on the server

Hey there,

I have the same problem as other users described in earlier posts: If I'm uploading my gallery on to the server a message comes up saying:

TiltViewer requires JavaScript and the latest Flash player. Get Flash here.

Yet, I do have both because otherwise I wouldn't have been able to watch it locally, right? If I open the ...TiltViewer.swf it shows me only the sample pictures.
Here's the link to my website: http://www.weisenbacher.de/StefansFotos … index.html

I do have experience in building websites, but I can't find any reasonable reason that I can think of, why this doesn't work. I'm using FileZilla as FTP-Software, tired also changing the transfer type. Anyone has an idea?

Thanks
Stefan

Re: Same problem as others before... it does not work on the server

Viewing the source there is no doctype declaration and everything is on one line for kicks try reformatting it.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>
      Toronto - January 2010 - powered by the AirtightInteractive Tiltviewer Picasa template from
      www.paulvanroekel.nl
    </title>
    <script type="text/javascript" src="swfobject.js">
</script>
    <style type="text/css">
/*<![CDATA[*/
    /* hide from ie on mac \*/ html { height: 100%; overflow: hidden; } #flashcontent { height: 100%; } /* end hide */ body { height: 100%; margin: 0; padding: 0; background-color: #000000; color:#ffffff; font-family:sans-serif; font-size:40; } a { color:#cccccc; }
    /*]]>*/
    </style>
  </head>
  <body>
    <div id="flashcontent">
      TiltViewer requires JavaScript and the latest Flash player. <a href=
      "http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a>
    </div><script type="text/javascript">
//<![CDATA[
    var fo = new SWFObject("TiltViewer.swf", "viewer", "100%", "100%", "9.0.28", "#000000");
    // TILTVIEWER CONFIGURATION OPTIONS 
    // To use an option, uncomment it by removing the "//" at the start of the line 
    // For a description of config options, go to: 
    // http://www.airtightinteractive.com/projects/tiltviewer/config_options.html 
    //FLICKR GALLERY OPTIONS // To use images from Flickr, uncomment this block 
    //fo.addVariable("useFlickr", "true"); 
    //fo.addVariable("user_id", "48508968@N00"); 
    //fo.addVariable("tags", "jump,smile"); 
    //fo.addVariable("tag_mode", "all"); 
    //fo.addVariable("showTakenByText", "true"); 

    // XML GALLERY OPTIONS 
    // To use local images defined in an XML document, use this block 
    fo.addVariable("useFlickr", "false"); 
    fo.addVariable("xmlURL", "gallery.xml"); 
    fo.addVariable("maxJPGSize","900"); 

    //GENERAL OPTIONS 
    fo.addVariable("useReloadButton", "false"); 
    fo.addVariable("columns", "5"); 
    fo.addVariable("rows", "5"); 
    //fo.addVariable("showFlipButton", "true"); 
    fo.addVariable("showLinkButton", "false"); 
    //fo.addVariable("linkLabel", "View image info"); 
    fo.addVariable("frameColor", "0x000000"); 
    fo.addVariable("backColor", "0xFFFFFF"); 
    fo.addVariable("bkgndInnerColor", "0xFFFFFFF"); 
    fo.addVariable("bkgndOuterColor", "0x0FFFFFF"); 
    fo.addVariable("langGoFull", "Fullscreen - Vollbildschirm"); 
    fo.addVariable("langExitFull", "Exit Fullscreen - Vollbildschirm verlassen"); 
    //fo.addVariable("langAbout", "About"); 
    // END TILTVIEWER CONFIGURATION OPTIONS 
    fo.addParam("allowFullScreen","true"); 
    fo.write("flashcontent"); 
    //]]>
    </script>
  </body>
</html>
Mike Richards
SimpleViewer Support Team.

Re: Same problem as others before... it does not work on the server

Hi there,

I uploaded all the data using 'binary' as transfer type and with that it worked! Strange thing, because before I only uploaded the swf.-file and the js-file like that.

Thank you
Stefan

Re: Same problem as others before... it does not work on the server

Hi Mike,

I'm having the same issue with the "Flash Player Install" message coming up on Dream Weaver when I try to run Tiltviewer. Yet the index.html file for Tiltviewer on my internal file is ok. Only when I try to load it to the Iweb page I get error message. Code looks fine to me. Followed all steps:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>TiltViewer</title>
<script type="text/javascript" src="swfobject.js"></script>
<style type="text/css">   
    /* hide from ie on mac \*/
    html {
        height: 100%;
        overflow: hidden;
    }
   
    #flashcontent {
        height: 100%;
    }
    /* end hide */

    body {
        height: 100%;
        margin: 0;
        padding: 0;
        background-color: #000000;
        color:#ffffff;
        font-family:sans-serif;
        font-size:40;
    }

    a {   
        color:#cccccc;
    }
</style>
</head>
<body>
    <div id="flashcontent">TiltViewer requires JavaScript and the latest Flash player. <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash here.</a></div>
    <script type="text/javascript">
   
        var fo = new SWFObject("TiltViewer.swf", "viewer", "100%", "100%", "9.0.28", "#000000");           
       
        // TILTVIEWER CONFIGURATION OPTIONS
        // To use an option, uncomment it by removing the "//" at the start of the line
        // For a description of config options, go to:
        // http://www.airtightinteractive.com/proj … tions.html
                                                           
        //FLICKR GALLERY OPTIONS
        // To use images from Flickr, uncomment this block
        fo.addVariable("useFlickr", "true");
        fo.addVariable("user_id", "40126473@N05");
        fo.addVariable("tags", "AB2010");
        fo.addVariable("tag_mode", "all");
        //fo.addVariable("showTakenByText", "true");           
       
        // XML GALLERY OPTIONS
        // To use local images defined in an XML document, use this block       
        fo.addVariable("useFlickr", "true");
        fo.addVariable("xmlURL", "gallery.xml");
        fo.addVariable("maxJPGSize","640");
       
        //GENERAL OPTIONS       
        fo.addVariable("useReloadButton", "true");
        fo.addVariable("columns", "4");
        fo.addVariable("rows", "3");
        fo.addVariable("showFlipButton", "true");
        //fo.addVariable("showLinkButton", "true");       
        //fo.addVariable("linkLabel", "View image info");
        //fo.addVariable("frameColor", "0xFF0000");
        //fo.addVariable("backColor", "0xDDDDDD");
        //fo.addVariable("bkgndInnerColor", "0xFF00FF");
        //fo.addVariable("bkgndOuterColor", "0x0000FF");               
        //fo.addVariable("langGoFull", "Go Fullscreen");
        //fo.addVariable("langExitFull", "Exit Fullscreen");
        //fo.addVariable("langAbout", "About");               
       
        // END TILTVIEWER CONFIGURATION OPTIONS
       
        fo.addParam("allowFullScreen","true");
        fo.write("flashcontent");           
    </script>   
</body>
</html>

Thanks for all your help big_smile

Re: Same problem as others before... it does not work on the server

Only when I try to load it to the Iweb page I get error message.

Is the code up online? If so please post the URL to the gallery having the issue.

Mike Richards
SimpleViewer Support Team.

Re: Same problem as others before... it does not work on the server

Mike,

here's the url...

http://www.artbazaar.tv/Photos.html

The weird thing though it's working now! I didn't touch it or manipulate the code.