Topic: embedded autoviewer on joomla

Hello, I am unable to embed autoviewer in my html page. My html is in a different path of the autoviewer files folder. I use joomla so I don't know the path of my page. Do I need the pro version to do that? Please help, I am going crazy   neutral
my html page is this: http://www.gnufoto.it/foto/live/autoviewer-rock.html
and the folder with the autoviewer files is this: http://www.gnufoto.it/images/autoviewer_gallery/photos/

Thanks,
Simone

Re: embedded autoviewer on joomla

This is the embedding code you have in your page:

<script src="/images/autoviewer_gallery/photos/swfobject.js" type="text/javascript"></script>
<div id="flashcontent">AutoViewer requires JavaScript and the Flash Player.  <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">// <![CDATA[
var fo = new SWFObject("viewer.swf", "viewer", "800", "600", "8", "#181818");
fo.write("flashcontent");
// ]]></script>
<!-- path of autoviewer files: images/autoviewer_gallery/photos/ -->

You need to add the path before the viewer.swf i.e. 
var fo = new SWFObject("images/autoviewer_gallery/photos/viewer.swf", "viewer", "800", "600", "8", "#181818");

You also need to point to the XML, because it is not in the same directory. Just before fo.write add fo.addVariable("xmlURL", "images/autoviewer_gallery/photos/gallery.xml");

So it should look like this:

<script src="/images/autoviewer_gallery/photos/swfobject.js" type="text/javascript"></script>
<div id="flashcontent">AutoViewer requires JavaScript and the Flash Player.  <a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">// <![CDATA[
var fo = new SWFObject("images/autoviewer_gallery/photos/viewer.swf", "viewer", "800", "600", "8", "#181818");
fo.addVariable("xmlURL", "images/autoviewer_gallery/photos/gallery.xml");
fo.write("flashcontent");
// ]]></script>
<!-- path of autoviewer files: images/autoviewer_gallery/photos/ -->
Mike Richards
SimpleViewer Support Team.

Re: embedded autoviewer on joomla

thanks a lot for the reply.
after different trials I had success!
The path of viewer.swf and gallery.xml needs the "/" at the start, because it is an absolute path, of course! (yes.. of course..).
And, in the gallery.xml the images path's has to be absolute too.
Bye!