Topic: Help! SimpleViewer/FireFox Flash Problem.

I purchased SimpleViewer Pro and have version 1.7.1.

On my website when I open a gallery, it brings up the upgrade flash message, but I have flash installed.

I have flash 10 installed.

I edited the PHP file to show me what version the getFlashVersion() function is returning, and it is returning "0" as the version, which is why it isn't working.

Anyone know how to update it so that it will detect version 10 properly?

If I just add a catch for 0, if no flash is installed does it also say 0?

Also, when flash goes to 11 I'm assuming it will return "1" and that will break it again.

Apparently the flash_detect.js is the issue, but I can't find a newer version that works.

Re: Help! SimpleViewer/FireFox Flash Problem.

Hi,

I would recommend upgrading to SimpleViewer v2.0 which handles all Flash player versions correctly.

Felix Turner
SimpleViewer Support Team.

Re: Help! SimpleViewer/FireFox Flash Problem.

Felix wrote:

Hi,

I would recommend upgrading to SimpleViewer v2.0 which handles all Flash player versions correctly.

Certainly.  Where can I download SimpleViewer Pro v2.0 for free?  I can't seem to find a place to do that.

If not available for free, then I would rather actually fix the problem than spend money on something unnecessary.  It works fine in IE so the version 10 can run it just fine, so why bother upgrading?

Re: Help! SimpleViewer/FireFox Flash Problem.

What is the URL of the gallery you are having issues with?

You can get a free upgrade from 1.7.1 to 1.9, if you need a download link fill out this form.

Mike Richards
SimpleViewer Support Team.