Topic: Gallery works in IE8, but not IE6

Hi there

I upgraded from V1 Simpleviewer to V2 Simpleviewer Pro

My old galleries are working fine in IE6 & 8, but my new ones don't seem to work in 8

The working one is at http://www.shenstone.me.uk/galleries/la … index.html
The one that is not working is http://www.shenstone.me.uk/galleries/la … index.html (Watch out for the Tom Jones track I'm just playing )

I know IE6 is poor, but we still have to use it at work and I show people shows from my site sometimes

I've looked at the embed code a few times and I can't see it if it's in the HTML

Regards
Andy

Re: Gallery works in IE8, but not IE6

I would start with fixing the HTML page errors.

Mike Richards
SimpleViewer Support Team.

Re: Gallery works in IE8, but not IE6

Thanks for the input, but most of that's irellevant to the posting I made - it's just changes to HTML standards that have come along since I 1st wrote the pages that I've not had time to keep up with (and frankly see no point in - people are trying to push HTML into a programming language not a document markup lanuage - if I wanted to code I'll do it in C#)

As the pages display fine in the newer browsers it's not causing any issues that IE8 is having any issues and of course IE6 wasn't designed to have to meet the latest standards so changing over to them would probably cause more problems not less

I know it's old and we all don't want to use IE6, but are there ANY known issues with IE6 I can't find any mention so I assumed not, but I'd like to see a defintive statement one way or another

Regards
Andy

Re: Gallery works in IE8, but not IE6

Yup

Cleaned it using the on-line tools offered and I see no difference

Regards
Andy

Re: Gallery works in IE8, but not IE6

There are no known issues with IE6. Most of the time when a page is working in one browser and not another we find it to be one of the following issues HTML errors, CSS errors or conflicting JavaScripts. If you go directly to the swf does it work for you in IE6? You could also try one of the other embed options if SWFObjects is giving you issues.

For example:

<object data="simpleviewer.swff?galleryURL=gallery.xml" type="application/x-shockwave-flash" height="100%" width="100%">
    <param value="simpleviewer.swf?galleryURL=gallery.xml" name="movie">
    <param value="333333" name="bgcolor" />
    <param value="true" name="allowfullscreen" />
    <param value="always" name="allowscriptaccess" />
    <param value="galleryURL=gallery.xml" name="flashvars" />
</object>
Mike Richards
SimpleViewer Support Team.

Re: Gallery works in IE8, but not IE6

I thought I would post that I have resolved my gallery issues by totally rewriting the pages to avoid tables

For some reason the DIV statement that contained the V2 simpleviewer broke the table even though the table structure was quite happy with the V1 simpleviewer