i've been using postcard viewer for 6 months now and this is the first time it doesn't work on firefox. when i click my postcard viewer gallery page on firefox it asks me to update my flash player, i already have version 9,0,16,0 installed and it still doesn't work. so i tried it on internet explorer which i hate and has the version 8,0,22,0 installed and it's working fine. At first i assumed that it's version 9,0,16,0 that's causing the problem, but i tried it on my sister's laptop with internet explorer and the flash version 9,0,16,0 and it works.

so yeah, anyone know what the problem is with firefox? thank you.