I have got exactly the same problem. Postcard viewer is working properly with Internet Explorer (with Flash Player 8).
But when I tried to open a galery with Firefox I have a message to update the flash player (which is not possible because I already have 9.0.16).
Does someone know what to do ?
Thanks