hi,

From a end-user's(meaning: visitors and guest to the simpleview gallery) POV, I have been experiencing the same problem just because i am a mac user.
I get directed to a page that asks me to update my flash player when my flash player is the most updated version. The strange thing is, I am able to access galleries that are still using simpleviewer 1.7. Also i am able to see the gallery here.

Any ways to resolve the problem so that end-users will not encounter this problem anymore? Cheers.