1

(30 replies, posted in SimpleViewer v1)

If i could kiss you I would.  Thanks Jay.  The really should add this to the instruction list!

aF

I figured it out.

To make the simpleviewer background transparent with an iframe, you have to go to the simpleviewer index.html file. Half way down in the code look for "body" you have to delete the lines for background-color.

Then under:
var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "7", "#000000");

Add this:
fo.addParam("wmode","transparent");

In all the posts I have read about adding "wmode", "transparent" , no one mentioned that you have to delete the line regarding background-color. It took a few hours until I got lucky and took a guess at deleting that line.

Hope this helps others,
Jay W

Ok...so after some more fooling around I figured it out.


See here: 4. My images show locally, but not when I upload them to my webserver. What are possible problems?

Check your image paths and filenames exactly match the names specified in the XML file. Most servers are Case Sensitive. This means the letter cases in the filename must exactly match those in the XML document (for example ".jpg" is not the same as ".JPG").

Another possible problem is if your webserver has  'Hotlink Protection' enabled. Hotlink Protection breaks SimpleViewer. Check with your webserver administrator.

Yet another possible problem is if you are using 'Fetch' to upload your files. Older versions of Fetch break SWFs on upload. Upgrade Fetch or use a different FTP app.

So i uploaded my files using a different ftp and it worked.  Cyberduck.

Hope that helps!!!!!!!

ok clearly i started a new topic on this w/o realizing this was here.

all these posts w/ people having the same problem...on the publishers site and NO ONE has an answer???

i only have this issue while exporting from lightroom 2 btw.  aperture 2 works fine.

aF

Recently I have begun using LR2 more and in doing so the airtight galleries are already loaded.  Sweet.  So exporting them to my hard disk and opening the swf works fine but when I upload the folder to my site and test it out the page gives me a "cant find flash error AutoViewer requires Adobe Flash. Get Adobe Flash. If you have Flash installed, click to view gallery"

Clearly I have flash as my other galleries work on my site.  So now...very confused.  Thanks for the help!

(working example under my site afeinphoto com and galleries and then abstract)

Aaron



-----------------------


Uploaded the gallery with another ftp client and it worked.   I used Cyberduck for the working and CuteFTP for the one that didnt.

Hope that helps

5

(0 replies, posted in SimpleViewer v1)

Hello all.  Did some searching and not sure why this is occuring.

I create my simpleviewer galleries using Aperture's FlashExporter plugin.  When I view my site on my comp/browser I see the caption/file name under the thumbnail arrows...however most people I talk to do not see this.  All help is greatly appreciated.

Aaron


example:
under my site go to galleries then abstract, or similar, my handle is my web addy

thanks!!