1

(11 replies, posted in SimpleViewer-Pro v1)

I've finished cleaning up the CSS and JS libraries for the site for the moment. I've updated the SWFObject as you requested, and now it doesn't work at all.

I've set up a page which won't be modified, http://test2.mtjit.com/jg-index2.html that has the simpleviewer code in it.

The gallery is in the Commissions tab, and then click on Portfolios.

Thanks,
--Mark

2

(11 replies, posted in SimpleViewer-Pro v1)

Hi Mike,

Thanks for your efforts. I'm cleaning up the stylesheets now and getting the site finished. I'll post a reply when I'm done. Have put in the new library as you suggested.

I'm working on an alternate method to do the galleries at the moment. Would really like to use simpleviewer, though.

--Mark Johnson

3

(11 replies, posted in SimpleViewer-Pro v1)

Thanks. Corrected that and ran the page against the HTML Validator at w3c.org. There are now no errors but the behavior stays the same.

4

(11 replies, posted in SimpleViewer-Pro v1)

I've added this to the head:

<script type="text/javascript" src="lib/swfobject.js"></script>
<script type="text/javascript">
            var flashvars = {};
            flashvars.firstImageIndex = "0";
            var params = {};
            params.play = "true";
            params.menu = "false";
            params.quality = "best";
            params.scale = "noscale";
            params.allowfullscreen = "false";
            params.allowScriptAccess = "sameDomain";
            params.wmode = "transparent";
            params.xmlDataPath="commissions.xml";
            var attributes = {};
            attributes.id = "flashContent";
            swfobject.embedSWF("viewer.swf", "flashContent", "100%", "100%", "8.0.0", false, flashvars, params, attributes);
</script>

=========
and this to the body:
=========

<div id="flashContent">
    <p>In order to view these galleries you must have <a href="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash">Adobe Flash Player</a> installed.
    If you know that you have Flash installed, then please ensure JavaScript and/or Active Content are enabled.</p>
</div>

=========

and now it doesn't work in IE or Mac. I have to have three galleries on this page, btw.

The gallery I am working on at the moment is in the "Collections" tab all the way to the right.

5

(11 replies, posted in SimpleViewer-Pro v1)

The site I'm working on is at http://test2.mtjit.com.

6

(11 replies, posted in SimpleViewer-Pro v1)

Thanks. Is there an example of how to use the object tag to load a gallery with a transparent background? I'm on a short deadline and don't have the time to read through this site. --Thanks.

I have one page with two galleries on it; works fine on Mac Safari and XP Safari and Firefox as well. On IE8 on XP, I get "Gallery Not Found".

Have paths set as:

        imagePath="commissions/images/"
    thumbPath="commissions/thumbs/"

Any suggestions as to why IE doesn't like this? XML files for both are in the root directory of the site.

Thanks for your help.

8

(3 replies, posted in SimpleViewer-Pro v1)

Thanks, that worked fine.

Is there a way to move the left and right arrows <-  and -> below the thumbnails instead of on the same line as the thumbnails.

Thanks for your eariler reply. Much appreciated.

9

(3 replies, posted in SimpleViewer-Pro v1)

I've just purchased SimpleViewer Pro and am trying to configure it for a website that has a background that faces towards the bottom. I need to find out how to set the viewer on top of this background so that it is transparent. Any suggestions?