tkendrick wrote:

My dropdown menu does not display over the gallery when it loads http://www.scgreenscapes.com/portfolio/gallery.php

I looked over your topics, but none have worked.

Have you tried z-index in your CSS script?

Hello Simpleviewer developer team,

I love the Simpleviewer product, the flash version is great but I do miss many configurable CSS layout features in the mobile non-flash.
I have tried to set an image border in a child class and it worked except that the picture is cut-off. The javascript is ignoring that the image is slightly larger because of the border. Using a border in the parent container does also not work because the image is smaller than the parent container.

What I like is that I can use one file the gallery.xml which I can configure with the same settings for the flash and non-flash gallery.

Thanks in advance, it is a great programs.

3

(6 replies, posted in SimpleViewer-Pro v2)

Steven Speirs wrote:

How can I get a border around the image without the picture being cut-off.

I do not know.
As I mentioned, I am not a developer of SimpleViewer and I have no insight into the 'svcore' files.
Trial and error may well be your best option.

OK, thanks for your help. I shall make a feature request for the non-flash gallery.

kind regards
Hans

4

(6 replies, posted in SimpleViewer-Pro v2)

Steven Speirs wrote:

Modification of files within the 'svcore' folder is not supported.
All settings are there for a purpose but as I am not a developer of SimpleViewer, I do not know which settings refer to what and can be 'safely' changed. Nothing in the 'simpleviewer.css' file has been designed to be user-changeable. (I also do not know what you are looking to change.)
The image you refer to is the SimpleViewer-Standard badge which is not used in Pro galleries.
I have not tried creating and using a new 'assets.png' file. Again, I do not know the specifications (dimensions of each image within the file) but you could certainly try to work it out and create your own 'assets.png' file though I cannot guarantee that it will work.

Hi Steven,

Thanks for your reply, I am sorry to tell you but I do have the pro galleries and the referred files are part of the pro download.

User-changeability:
The css file is full of comments and settings for the hand hold devices are even commented out. Looking at the content of the file give me the idea that non-flash is only properly configured for default settings, IE9 but not for iphone, android or iPad. Hard to call it mobile. :)

5

(6 replies, posted in SimpleViewer-Pro v2)

I want my non-flash gallery as consistent in layout as the flash one. The mean pictures in the flash one has a two pixels wide, gray solid line around it. I have changed .simpleviewer-mobile-glry img from border:none to border:2px #a6a6a6 solid;.

Simpleviewer.js is not build to handle a image border in its calculation.

How can I get a border around the image without the picture being cut-off.

You can find the result at http://www.delosgaia.nl/pictures_madeira.htm, goto Intro or Photoalbum

6

(6 replies, posted in SimpleViewer-Pro v2)

I want to change simpleviewer.css because the layout of the non-flash is not what I am looking for. Which CSS settings can I change and which CSS settings are mandatory?

In sv-nav-log is a background downloaded from simpleviewer.net, where is this background used in simpleviewer-pro?

Can I use other assets?

regards
Hans

Hi Steven,

Thanks for your reply, your solution with galleryURL is a better one. Yes I am using v2.2.0 and it solved me many problems with the non-flash gallery.

regards
Hans

I do have two simpleviewer gallery on several website pages. I am using:
<script type="text/javascript">
var flashvars = {};
flashvars.galleryURL = "design3/header/header_www.xml";
var params = {};
params.wmode = "transparent";
simpleviewer.ready(function(){simpleviewer.load("box_slideshow","100%", "100%", "555555", true, flashvars, params);});
</script>

This is working fine for flash but give problems with the non-flash galleries. I have noticed that the variable flashvars is global for the page in the non-flash version but local in the flash galleries. This is annoying.
I have to use the next to get it working in the non-flash galleries:
<script type="text/javascript">
var flashvars1 = {};
flashvars1.galleryURL = "picturegallery/portugal/madeira_1.xml";
var params = {};
params.wmode = "transparent";
simpleviewer.ready(function(){simpleviewer.load("flashcontent","100%", "100%", "transparent", true, flashvars1, params);});
</script>
<script type="text/javascript">
var flashvars2 = {};
flashvars2.galleryURL = "design3/header/header_www.xml";
var params = {};
params.wmode = "transparent";
simpleviewer.ready(function(){simpleviewer.load("box_slideshow","100%", "100%", "555555", true, flashvars2, params);});
</script>
without the different flashvars variable the header_www.xml is used for both galleries in the non-flash ones.
This is not a nice solution and I think it will need a change in simpleviewer.js

I have made a slideshow with Simpleviewer Pro 2.1.3, the show is working perfectly with flash but not with the Mobile player (www.delosgaia.nl/index.htm)
Have I made a mistake or is this not possible?

Hi,
I would like to see support for Exif information in the gallery.
Also more flexibility in svBuilder-Pro with gallery.xml filenames and gallery folderstructure. I change the name and location of gallery.xml after I have created a new gallery. It is always a problem when I need to change or update a gallery.

Cheers Hans

11

(2 replies, posted in SimpleViewer-Pro v2)

Mike Richards wrote:

SimpleViewer currently does not support a zooming on the images.

I understand and this is a feature request for the next build. It is easy to do with a Java scipt.

12

(2 replies, posted in SimpleViewer-Pro v2)

I have a feature request:
The option to zoom in and out at the pictures. Not at the complete gallery, this is a feature of Flashplayer

You must use z= into your styles. Z=100 is higher in the stack then z=1 so z=100 is on top of z=1. Set the unsorted list for the menu on a higher z-level.

Little advice. use the embedSWF

<script type="text/javascript" src="design2/header/svcore/js/swfobject.js"></script>
<script type="text/javascript">
            var flashvars = {};
            flashvars.galleryURL = "design2/header/header_www.xml";
            var params = {};
            params.allowscriptaccess = "always";
            params.bgcolor = "FFFFFF";
            params.wmode = "transparent";
            swfobject.embedSWF("design2/header/svcore//swf/simpleviewer.swf", "box_slideshow", "998", "294", "9.0.124", false, flashvars, params);
</script>
see www.delosgaia.nl

It seems you have a DIV inheritence in your webpages. The DIV maincontent has a height of 100%.
Solution: Make a style for sv-container with proper min-height or absolute height

Mike Richards wrote:

It is not only "OVERLAY_BOTTOM" but I have the same problems with "OVERLAY_TOP"

Yes, you are correct overlay top will functions the same as overlay bottom.

I am still trying to get a line break in my caption but still without succes.

The linke breaks (<br>) that you have placed in your captions seem to be functions just fine for me and the text does not appear to be overrunning the image numbers.

Is it possible that the Simpleviewer caption text field is not a multiline text field?

No, SimpleViewer supports multi line captions for an example see photo 6 here.

I can tell you that the caption in Overlay_Top or Overlay_Bottom is not multi-line in Simpleviewer aswell as in a webpages as with SVBuilder_Pro.  This must be a bug in Simple Viewer.

I have found it, it is the Caption Padding, anything below 4 and the next line by wrap around don't show up.

Thanks Felix,

The image size default are set at 1024x768 with quality 80. Is it possible to change these default settings?

Mike Richards wrote:

Yes you can add html to your captions, but the only supported tags are anchor, underline, bold, break and font.

I am still trying to get a line break in my caption but still without succes. I have checked the textfield in Action script 3.0 and you need a multiline text field to use succesfully a line break.

Is it possible that the Simpleviewer caption text field is not a multiline text field?

Mike Richards wrote:

Currently the only option is to set it's color preloaderColor, you could hide it by setting it to have the same color as the background.

Thanks, I have a picture as background in the DIV and I am using transparant as flash background in my slideshows.

Mike Richards wrote:

It looks like captionPosition="OVERLAY_BOTTOM" can only handle a certain amount of text by default, but you can force it to use more by adding <br> tags.

It is not only "OVERLAY_BOTTOM" but I have the same problems with "OVERLAY_TOP"

Is it possible for me to change the Flash load animation into something more dynamic?

Mike Richards wrote:

Right now you seem to be using  link breaks, is the issue occurring when you are or are not using the line breaks?

I have used <br> in gallery.xml. Normally I am using <br /> in websites. Both don't give me the desired result. You have my permission to download the gallery.xml file.
The path is http://www.delosgaia.nl/design2/header/gallery.xml

Mike Richards wrote:

I noticed that Caption width and height in Overlay Caption are not working as expected. Text is still full width of picture

Do you have an example of the issue and what exactly are you expecting?

When the caption text is longer then the picture width I expect wrap-around. This is not working in all cases, for instance.  When the text is just a few letters longer then the picture wrap-around does not take place. Is this a known problem?
Picture number overwrites the Caption text.

I will, have to check to see if it is a known issue, for now I would suggest adding a <br> tag to force a line break.

See http://www.delosgaia.nl/design2/header/test.html. image number is on, caption is longer then picture width. Caption height is increased but no wrap-around of caption text.

Questions about Caption.

Is it possible to use HTML code in the Caption?
I want to use only left and right pading and not top and bottom, is this possible?

I noticed that Caption width and height in Overlay Caption are not working as expected. Text is still full width of picture

When the caption text is longer then the picture width I expect wrap-around. This is not working in all cases, for instance.  When the text is just a few letters longer then the picture wrap-around does not take place. Is this a known problem?

Picture number overwrites the Caption text.

Thanks