1

(1 replies, posted in SimpleViewer v2)

I am using dreamweaver cs4 to post a gallery, and it is saying "Gallery XML Not found"...the web link is www.TheSarahHornerBand.com...it is on the left side at the bottom...I need some help diagnosing it?

I cant view it locally or on the web...

Oh boy....I loaded it on the server and now the thumbs appear online but not the fullsize images?

That did it, thank you very much!!!!

Here is my .xml html...Are my paths right?

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="380" maxImageHeight="380" textColor="0xffffff" frameColor="0xffffff" frameWidth="20" stagePadding="40" navPadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="left" vAlign="center" hAlign="center" title="GTC Studios Design" enableRightClickOpen="false" backgroundImagePath="SimpleViewer/Images" imagePath="SimpleViewer/Images" thumbPath="SimpleViewer/thumbs">
<image>
    <filename>FallingUpAcousticEPCDcover.jpg</filename>
    <caption>FallingUpAcousticEPCDcover.jpg</caption>
</image>
<image>
    <filename>SHBtshirtHolyShirt.jpg</filename>
    <caption>SHBtshirtHolyShirt.jpg</caption>
</image>
<image>
    <filename>TheSHBCoverUPCover.jpg</filename>
    <caption>TheSHBCoverUPCover.jpg</caption>
</image>
<image>
    <filename>TheSHBPromoCDCover.jpg</filename>
    <caption>TheSHBPromoCDCover.jpg</caption>
</image>
<image>
    <filename>XmasCDcover.jpg</filename>
    <caption>XmasCDcover.jpg</caption>
</image>
</simpleviewerGallery>

Here is my current script on my page...

<script type="text/javascript" src="SimpleViewer/swfobject.js"></script>
<div id="flashcontent">SimpleViewer requires JavaScript and the Flash Player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">
var fo = new SWFObject("SimpleViewer/viewer.swf", "viewer", "640", "295", "8", "#FFF");
fo.addVariable("xmlDataPath", "SimpleViewer/gallery.xml");
fo.write("flashcontent");   
</script>
<p>&nbsp;</p>
   
   
  </div>
  <div id="footer">
    <p>
      <!-- end #footer -->
    </p>
    <p>&nbsp; </p>
  </div>
<!-- end #container --></div>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
var MenuBar1 = new Spry.Widget.MenuBar("MenuBar1", {imgDown:"SpryAssets/SpryMenuBarDownHover.gif", imgRight:"SpryAssets/SpryMenuBarRightHover.gif"});
//-->
</script>
</body>
</html>

It is all coming up on my page now after I loaded correctly on the server and changes the script path, but now no images appear, just X's, the script the the .xml page seem to be right, i think.

Unless I removed the wrong one, i don't see another one?

i removed the extra script, still nothing

Alright that should do it, I am pretty sure it loaded without the sprymenubar on the graphicdesign.hml paeg

It dosen't work when I view it locally, should I delete the sprymenubar on the page and upload it to the server and try it that way?

I deleted the spry menu bar from the the GraphicDesign.html page and it still didn't work, same message "SimpleViewer requires JavaScript and the Flash Player. Get Flash."

I need some help, I have Dreamweaver CS4 and need to imbed simpleviewer into my current html page.  I have the most currnet flashplayer and all.  How do I do this?  http://www.skinnyatlas.net/GraphicDesign.html

This is in my html page

<script type="text/javascript" src="swfobject.js"></script>
<div id="flashcontent">SimpleViewer requires JavaScript and the Flash Player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>
<script type="text/javascript">
var fo = new SWFObject("SimpleViewer/viewer.swf", "viewer", "640", "640", "8", "#181818");
fo.addVariable("xmlDataPath", "SimpleViwer/gallery.xml");
fo.write("flashcontent");   
</script>

and here is my .xml:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewerGallery maxImageWidth="480" maxImageHeight="480" textColor="0xffffff" frameColor="0xffffff" frameWidth="20" stagePadding="40" navPadding="40" thumbnailColumns="3" thumbnailRows="3" navPosition="left" vAlign="center" hAlign="center" title="SimpleViewer Title" enableRightClickOpen="false" backgroundImagePath="" imagePath="" thumbPath="">
<image>
    <filename>FallingUpAcousticEPCDcover.jpg</filename>
    <caption>FallingUpAcousticEPCDcover.jpg</caption>
</image>
<image>
    <filename>SHBtshirtHolyShirt.jpg</filename>
    <caption>SHBtshirtHolyShirt.jpg</caption>
</image>
<image>
    <filename>TheSHBCoverUPCover.jpg</filename>
    <caption>TheSHBCoverUPCover.jpg</caption>
</image>
<image>
    <filename>TheSHBPromoCDCover.jpg</filename>
    <caption>TheSHBPromoCDCover.jpg</caption>
</image>
<image>
    <filename>XmasCDcover.jpg</filename>
    <caption>XmasCDcover.jpg</caption>
</image>
</simpleviewerGallery>

Everything is in the a folder labeled "SimpleViewer" in the website folder (images, xml, swf, swobject.js)

Help?