I was experiencing a very strange occurrence today, that I think some other users may have seen in the past.  I did not however see a fix that worked for me.

However, I figured out what was causing my problem, so I'll share just in case....

Here is how I fixed the blank add gallery issue.

My permissions on the "uploads" directory was correct.... 777

HOWEVER, my permissions on "wp-content" was also set to 777 for some reason.  Once I changed it to 755, ALL WAS WORKING AS PLANNED.

On one of my hosting accounts the 777 setting on wp-content displayed a "Internal Server Error" in the add gallery popup, but a different host simply displayed a blank add gallery popup.

Hope this might help some folks in the future.