excellent - thanks!

Is there a way to dial down the quality when resizing images in the "Add Images" screen of svManager?  It appears to resize at maximum jpg quality, whereas in some cases I'd prefer something like medium quality in Photoshop.

I'm using svManager version 1.8.1, build 120613 and adding images to a Juicebox gallery.

Thanks!

Swapping over the 'svcore' folders is all that is required to upgrade your galleries from v2.1.3 to v2.3.0.

oh ok sweet - even if I don't automate that's way more straightforward than I was expecting!

Thanks Steven, however:

I bought Juicebox builder but apparently it can't do this kind of grid thumbnail arrangement or mouseover control so that's out (although I am using Juicebox for something else).

Hence, I'd be going from  SimpleViewer-Pro v2.1.3 to SimpleViewer-Pro v2.3.0.  Does that sound any easier?

that did it - thanks Steven!

once I set relative paths on everything is there a more automated way to do the upgrades or is it just a matter of opening and saving 100+ galleries individually?

k I took out all the pictures with left brackets and the same thing happened:

Before hitting save in SVbuilder pro:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewergallery
 maxImageWidth = "420"
 maxImageHeight = "290"
 frameWidth = "6"
 thumbPosition = "RIGHT"
 title = "Best Explosive Stockless Assault Shotguns"
 showOpenButton = "FALSE"
 imageClickMode = "OPEN_URL"
 imageScaleMode = "NONE"
 imageDropShadow = "TRUE"
 imageVAlign = "BOTTOM"
 thumbWidth = "164"
 thumbHeight = "116"
 thumbPadding = "5"
 thumbVAlign = "TOP"
 changeImageOnHover = "TRUE"
 showNavButtons = "TRUE"
 showAutoPlayButton = "TRUE"
 titlePosition = "TOP"
 captionPosition = "BOTTOM"
 floatCaption = "FALSE"
 watermarkURL = "http://borderlandsbestgear.com/svmanager/watermark.png"
 watermarkHAlign = "CENTER"
 watermarkVAlign = "CENTER"
 watermarkPadding = "0">
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b4ZPR433AngryCrux.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b4ZPR433AngryCrux.jpg" linkURL="http://gearcalc.50webs.com/#tqstqklmlijjqjkkmfggmghhjmnnpbccizyytsrrnxxxxabbgxwuupojjtssm" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b4ZPR433BlastShotgun.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b4ZPR433BlastShotgun.jpg" linkURL="http://gearcalc.50webs.com/#tqstqklmlijjqjkkmfggmghhjmnnpbccizyytsrrnxxxxabcexwuupomgtssk" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b4ZPR43V3BlastShotgun.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b4ZPR43V3BlastShotgun.jpg" linkURL="http://gearcalc.50webs.com/#sprspkklkiijijjjlffflgggnmmmobbbhzzzusssoxxxxaabdxxuwppnhtttl" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b4ZPR43v3BlastHammer.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b4ZPR43v3BlastHammer.jpg" linkURL="http://gearcalc.50webs.com/#tqstqklmlijkjjkkmfggmghhomnnpbccizyytsrrnxxxxabbhxwtvpomgtssl" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b5ZPR433BlastDeath.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b5ZPR433BlastDeath.jpg" linkURL="http://gearcalc.50webs.com/#vsuvsknonillsjmmofiiogjjlmpprbeelzwwrspplxxxxadegxusspmketqqn" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g4/images/b5ZPR43v3BlastShotgun.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g4/thumbs/b5ZPR43v3BlastShotgun.jpg" linkURL="http://gearcalc.50webs.com/#vsuvsknonilmljmmofiiogjjqmpprbeelzwwrspplxxxxadegxurtpmketqqi" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
</simpleviewergallery>

After hitting save:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery 

    maxImageWidth="420"
    maxImageHeight="290"
    frameWidth="6"
    thumbPosition="RIGHT"
    title="Best Explosive Stockless Assault Shotguns"
    showOpenButton="FALSE"
    imageClickMode="OPEN_URL"
    imageScaleMode="NONE"
    imageDropShadow="TRUE"
    imageVAlign="BOTTOM"
    thumbWidth="164"
    thumbHeight="116"
    thumbPadding="5"
    thumbVAlign="TOP"
    changeImageOnHover="TRUE"
    showNavButtons="TRUE"
    showAutoPlayButton="TRUE"
    titlePosition="TOP"
    captionPosition="BOTTOM"
    floatCaption="FALSE"
    watermarkURL="http://borderlandsbestgear.com/svmanager/watermark.png"
    watermarkHAlign="CENTER"
    watermarkVAlign="CENTER"
    watermarkPadding="0"
    useFlickr="false"
    resizeOnImport="true"
    cropToFit="false"/>

next step is to just head to the simpleviewer pro forum?

So the problem seems to be in svBuilder rather than svManager – yes?

indeed

I notice a right-bracket character in some of your file names ']'. I would get rid of these before you do anything else. If that doesn't work then you'd be best to post in the SimpleViewer Pro forum.

*gulp* Removing the right brackets would be problematic since they exist in 99% of filenames across 100 galleries.  I'll give it a try...

When you create new galleries or clone them, SvManager will use the version of SimpleViewer in its master folder: svmanager/plugins/simpleviewer2/sv2master/svcore. Replace the whole svcore folder and its contents by the folder in your SimpleViewer Pro download or from your backup.

awesome - I guess I forgot about that : P  That fixed more stuff than I expected - thanks!

Jack said:

Your workflow seems logical. It seems that your gallery settings are making it through to the new gallery.xml file but the image tags in the xml file are lost. Can you establish exactly which step in your workflow is losing the image tags by looking at the xml file every step of the way?

k-
here's the original gallery: http://borderlandsbestgear.com/svmanager/g2/
here's the post-upgrade gallery: http://borderlandsbestgear.com/svmanager/sv23try1/

I grabbed the gallery.xml file at four points in sv-builder pro.  It seems unchanged until I hit Save in the Publish screen; then bye bye images:

Before:

<?xml version="1.0" encoding="UTF-8"?>
<simpleviewergallery
 backgroundColor = "0xFFFFFF"
 maxImageWidth = "420"
 maxImageHeight = "290"
 frameWidth = "6"
 thumbRows = "3"
 thumbPosition = "RIGHT"
 title = "Pearlescent Samples"
 showOpenButton = "FALSE"
 showFullscreenButton = "FALSE"
 imageClickMode = "OPEN_URL"
 imageScaleMode = "NONE"
 imageDropShadow = "TRUE"
 imageVAlign = "BOTTOM"
 thumbWidth = "164"
 thumbHeight = "116"
 thumbPadding = "5"
 thumbVAlign = "TOP"
 changeImageOnHover = "TRUE"
 titlePosition = "NONE"
 captionPosition = "BOTTOM"
 floatCaption = "FALSE"
 watermarkURL = "http://borderlandsbestgear.com/svmanager/watermark.png"
 watermarkHAlign = "CENTER"
 watermarkVAlign = "CENTER"
 watermarkPadding = "0">
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/DVL590FearsomeBessie.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/DVL590FearsomeBessie.jpg" linkURL="http://gearcalc.50webs.com/#tqstqklmuijjojklkfginghlimnpubcfjutnosrqixxxxabheutnppofltrrj" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/AR520Deathly]PunishingAvenger.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/AR520Deathly]PunishingAvenger.jpg" linkURL="http://gearcalc.50webs.com/#vsuvsknopilltjmmqfilngjnmmpstbeikurnpspnkxxxxadkhurnqplmktpoo" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/ZPR1200UFrenzied]HuntersJackal.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/ZPR1200UFrenzied]HuntersJackal.jpg" linkURL="http://gearcalc.50webs.com/#urturkmnpikkmjllofhhngiilmoosusopzxxssqqnxxxxacckusoopnhmtqqk" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/b5AR5902GloriousSerpens.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/b5AR5902GloriousSerpens.jpg" linkURL="http://gearcalc.50webs.com/#urturkmomikkrjllqfhkmgimnmorwbdhjzxuosqolxxxxusmmusmlpmnftqpq" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/TMP8DoubleStalker.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/TMP8DoubleStalker.jpg" linkURL="http://gearcalc.50webs.com/#tqstqklmpijkjjkkqfghoghjnmnovutpozyxrxxxxeffkabefutpnpooltrqo" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/uRWL760Devastating]SteelUndertaker.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/uRWL760Devastating]SteelUndertaker.jpg" linkURL="http://gearcalc.50webs.com/#vsuvsknouillujmmvfilqgjommptsurmlzwsrspngxxxxadljurmkpmietpon" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/b5HX530CobaltTsunami.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/b5HX530CobaltTsunami.jpg" linkURL="http://gearcalc.50webs.com/#urturkmnuikkqjlltfhjlgiljmoqqbdgezxvssqpmxxxxusmqusmppnjhtqpr" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/b5TK5FulguratingNemesis.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/b5TK5FulguratingNemesis.jpg" linkURL="http://gearcalc.50webs.com/#urturkmnrikkojllsfhimgiknmoptbdfgzxwqxxxxegglusolusokpnkftqqj" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
  <image imageURL="http://borderlandsbestgear.com/svmanager/g2/images/b4AX300PearlAries.jpg" thumbURL="http://borderlandsbestgear.com/svmanager/g2/thumbs/b4AX300PearlAries.jpg" linkURL="http://gearcalc.50webs.com/#urturkmnsikkljllmfhijgijomoppbdegzxwwsqqjxxxxusnousnnpnjntqql" linkTarget="">
    <caption><![CDATA[]]></caption>
  </image>
</simpleviewergallery>

After:

<?xml version="1.0" encoding="UTF-8"?>

<simpleviewergallery 

    backgroundColor="0xFFFFFF"
    maxImageWidth="420"
    maxImageHeight="290"
    frameWidth="6"
    thumbRows="3"
    thumbPosition="RIGHT"
    title="Pearlescent Samples"
    showOpenButton="FALSE"
    showFullscreenButton="FALSE"
    imageClickMode="OPEN_URL"
    imageScaleMode="NONE"
    imageDropShadow="TRUE"
    imageVAlign="BOTTOM"
    thumbWidth="164"
    thumbHeight="116"
    thumbPadding="5"
    thumbVAlign="TOP"
    changeImageOnHover="TRUE"
    titlePosition="NONE"
    captionPosition="BOTTOM"
    floatCaption="FALSE"
    watermarkURL="http://borderlandsbestgear.com/svmanager/watermark.png"
    watermarkHAlign="CENTER"
    watermarkVAlign="CENTER"
    watermarkPadding="0"
    useFlickr="false"
    resizeOnImport="true"
    cropToFit="false"/>

What should I do next?

btw:

1. I bought Juicebox builder but apparently it can't do this kind of grid thumbnail arrangement or mouseover control so that's out (although I am using Juicebox for something else).

2. After upgrading svManager to 1.8.1 I can no longer clone galleries without messing them up - the layout changes and the thumbnails all get resized into squares.  Also the word 'simpleviewer' shows up in the preload and the corner as if I'm using the free version.  I have a backup of everything under svManager 1.7.8 which worked fine, but I'd like to get this simpleviewer upgrade all sorted out now that Juicebox isn't an option for most of my stuff.

Thanks!

I've got about 100 SV galleries under an instance of svManager.

Original setup:
svManager version 1.7.8, build 110516
SimpleViewer-Pro v2.1.3

Target setup:
svManager version 1.8.1, build 120613
SimpleViewer-Pro v2.3.0

To upgrade svManager, I uploaded the new svManager directory over the old one and it looks fine.
To upgrade an SV gallery, I opened it in svBuilder Pro, clicked Publish, and Save.  Then I clicked 'Update' for it in the new svManager.

The result is that when I open that gallery, instead of images, I see "No Images Specified in Gallery XML"

Before upgrade: http://borderlandsbestgear.com/svmanager/g1/
After upgrade: http://borderlandsbestgear.com/svbackup/g1/

What am I missing?
Do I have to upgrade each of the 100 galleries in svBuilder Pro individually?
And is it an option to migrate them all to Juicebox?

Thanks!

k great thanks for all your help!

thanks Steven.

Steven Speirs wrote:

(3) Edited 'config.xml' file and uploaded it replacing previous version

This is equivalent to altering a gallery with svmanager, correct?  And it won't make any difference if the gallery is pulling linked pictures from flickr?

I made both changes you mentioned in post 7 and on IE8 it works.  If I delete a gallery image in svmanager and refresh the page then it's gone.  It seems like having the gallery open in multiple windows can interfere and make a deleted image show up as an X, but then if you close IE and open it, the changes are applied.  so IE looks good.

On Chrome though, refreshing doesn't show changes, and closing all Chrome windows seemed to have worked one time, but I can't make it work again.  Seems like only clearing browsing data with the top 4 check boxes checked shows the changes

Chrome is pretty important.  Where might I go from here?

P.S. I don't NEED it to work w/ simpleviewer 2.x,  but if you can confirm that it'll work with Juicebox in Chrome, I can get that.

Steven Speirs wrote:

The above gallery is a SimpleViewer v2 gallery...

k thanks I will try it soon - sorry about posting in the wrong forum - I was going of the svmanager version instead of simpleviewer's :P

^in svmaster/index.php?

and then changes should be fairly immediate?  or do I have to rebuild a gallery or somesuch?

Hi Steven,
Thanks for the quick reply.  I must be missing something though.  I posted about this because presently if I change a gallery (e.g. add an image, delete an image) I don't see a change until I clear the temp files out of my browser cache.  I don't think I've done an upgrade, so iirc these galleries were all made with svManager version 1.7.8, build 110516 (tho the first one was created with sv-builder pro I guess.
I was hoping that if I changed something about XML caching, I could avoid the cache clearing dance and see gallery changes as they happen.  What do you think I should do?

here is an example gallery: http://borderlandsbestgear.com/svmanager/g1/

Once you see it, I will delete 3 images if you want, and next time you look at the gallery, I bet you'll still see them.

Thanks,
Brian

P.S. I'm considering using Juicebox + flickr for another site but it would have to be updated on a per visit basis, like I'm trying to do here, or else it won't work : (

In this thread http://www.simpleviewer.net/forum/viewt … p?id=14080 I found:

Steven Speirs wrote:

In order to prevent the gallery's XML file being cached, use the following line in your embedding code before the fo.write("flashcontent"); line:

fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());

Three questions:
1. will this absolutely make it so that a gallery's content is fresh for each visit?
2. if I'm using simpleviewer galleries within svmanager, does that line just go into the svmaster/index.php?
3. do I have to do anything besides adding the line to apply the change to pre-existing galleries within the svmanager folder?

I'm currently using svManager version 1.7.8, build 110516
Thanks!

UPDATE: no additional gallery page visits were tracked.

Not sure what the deal is with g2 yesterday.  Fwiw that's the only gallery that's embedded in a page, and that page is the home page, which gets more traffc than anything else.  Why it logged a single visit yesterday alone doesn't immediately make sense given that there has been no change to the home page or g2 for several days.

Hi Steven,
I doublechecked the live index.php at that location^ and this is what it has been for the last few days:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" >
    <?php
      /* Leave this block of php code intact if customizing this page */
      error_reporting(0);
      $preferences = file_get_contents('preferences.txt');
      $preferences = unserialize($preferences);
      $title = htmlspecialchars($preferences['htmlTitle'], ENT_QUOTES, 'UTF-8');
      $galleryWidth = isset($preferences['galleryWidth']) ? "'".$preferences['galleryWidth']."'" : "'100%'";
      $galleryHeight = isset($preferences['galleryHeight']) ? "'".$preferences['galleryHeight']."'" : "'100%'";
      $useFlash = isset($preferences['useFlash']) ? strtolower($preferences['useFlash']) : 'true';
      $backgroundColor = isset($preferences['backgroundColor']) ? $preferences['backgroundColor'] : '0x222222';
      $backgroundColor = "'".ltrim(str_replace('0x', '', $backgroundColor), '#')."'";
      $flashVars = 'null';
      $params = 'null';
      $attributes = 'null';
      $useColorCorrection = isset($preferences['useColorCorrection']) ? strtolower($preferences['useColorCorrection']) : 'true';
    ?>
    <title><?php print $title; ?></title>
  </head>
  <body>
    <!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
    <script type="text/javascript">
      var flashvars = {};
      flashvars.galleryURL = "gallery.xml?nocache=<?php echo rand(); ?>";
      simpleviewer.ready(function () {
        simpleviewer.load(
          'sv-container',
          <?php print $galleryWidth; ?>,
          <?php print $galleryHeight; ?>,
          <?php print $backgroundColor; ?>,
          <?php print $useFlash; ?>,
          <?php print $flashVars; ?>,
          <?php print $params; ?>,
          <?php print $attributes; ?>,
          <?php print $useColorCorrection; ?>
          );
      });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->
  <a title="Real Time Web Analytics" href="http://getclicky.com/66497044"><img alt="Real Time Web Analytics" src="//static.getclicky.com/media/links/badge.gif" border="0" /></a>
<script src="//static.getclicky.com/js" type="text/javascript"></script>
<script type="text/javascript">try{ clicky.init(66497044); }catch(e){}</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/66497044ns.gif" /></p></noscript>
</body>
</html>

?

EDIT: weird - I just checked and it looks like that one particular gallery - g2 - shows a visit today - but no other galleries.  I'm certain that other galleries have gotten dozens of visits.  I reset a cache earlier today so maybe that has something to do with it(?).  I'll update what I'm seeing tomorrow.

Steven Speirs wrote:

Please post the URL to one of your galleries so that we can take a look.

here's one: http://borderlandsbestgear.com/svmanager/g2/

Hi Steven,
I did that^ a few days ago but no galleries show up in the Clicky results.  Everything else does though and I'm positive they're getting plenty of traffic.  Not sure if it helps, but this is the Clicky tracking code:

<a title="Web Analytics" href="http://getclicky.com/[my clicky number]"><img alt="Web Analytics" src="//static.getclicky.com/media/links/badge.gif" border="0" /></a>
<script src="//static.getclicky.com/js" type="text/javascript"></script>
<script type="text/javascript">try{ clicky.init([my clicky number]); }catch(e){}</script>
<noscript><p><img alt="Clicky" width="1" height="1" src="//in.getclicky.com/[my clicky number]ns.gif" /></p></noscript>
Steven Speirs wrote:

I'm using svmanager.

Thank you for this information.
If you wish to include a chunk of code in the index pages of all your galleries created by svManager, then you should insert the code immediately before the closing </body> tag in the 'svmanager\plugins\simpleviewer2\sv2master\index.php' file.

wow that sounds easy

I'm using svmanager.  I guess this looks like I'm embedding, but the URLs are just like www.site.com/svmanager/g11
Here's an index.php

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" >
    <?php
      /* Leave this block of php code intact if customizing this page */
      error_reporting(0);
      $preferences = file_get_contents('preferences.txt');
      $preferences = unserialize($preferences);
      $title = htmlspecialchars($preferences['htmlTitle'], ENT_QUOTES, 'UTF-8');
      $galleryWidth = isset($preferences['galleryWidth']) ? "'".$preferences['galleryWidth']."'" : "'100%'";
      $galleryHeight = isset($preferences['galleryHeight']) ? "'".$preferences['galleryHeight']."'" : "'100%'";
      $useFlash = isset($preferences['useFlash']) ? strtolower($preferences['useFlash']) : 'true';
      $backgroundColor = isset($preferences['backgroundColor']) ? $preferences['backgroundColor'] : '0x222222';
      $backgroundColor = "'".ltrim(str_replace('0x', '', $backgroundColor), '#')."'";
      $flashVars = 'null';
      $params = 'null';
      $attributes = 'null';
      $useColorCorrection = isset($preferences['useColorCorrection']) ? strtolower($preferences['useColorCorrection']) : 'true';
    ?>
    <title><?php print $title; ?></title>
  </head>
  <body>
    <!--START SIMPLEVIEWER EMBED -->
    <script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
    <script type="text/javascript">
      var flashvars = {};
      flashvars.galleryURL = "gallery.xml?nocache=<?php echo rand(); ?>";
      simpleviewer.ready(function () {
        simpleviewer.load(
          'sv-container',
          <?php print $galleryWidth; ?>,
          <?php print $galleryHeight; ?>,
          <?php print $backgroundColor; ?>,
          <?php print $useFlash; ?>,
          <?php print $flashVars; ?>,
          <?php print $params; ?>,
          <?php print $attributes; ?>,
          <?php print $useColorCorrection; ?>
          );
      });
    </script>
    <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->
  </body>
</html>
Steven Speirs wrote:

Before the </body> Index.php?

As a standard SimpleViewer gallery does not contain PHP pages, it would appear that you are embedding a gallery in your own PHP page ('Index.php'). This page should contain a </body> tag and your Clicky code should be placed immediately before it. Depending on how your PHP page is constructed, you may need to break out of PHP code to insert your Clicky code.

Hi Steven,
I'm not embedding; I just noticed that there was an index.php at [galleryname]/index.php
Where would I put it in a standard simpleviewer gallery?

http://getclicky.com/help/#website
Here^ Clicky Analytics says to put their tracking link right before the </body> tag on a given html page.  What does that mean in terms of a simpleviewer gallery?  Before the </body> Index.php?  Thanks!

your updated code got rid of one of the line breaks so that's progress!

I'll try the iframe method when I get a chance

EDIT: iframe method works freakin perfect.