Hi Steven

This is the first time I have used one of your products.  Turns out this is perfect for this page on the little site I am working on!

http://nealandjessie.com/postcardviewer/honeymoon.html

Though I'm sure I will need the Pro versions on commercial sites.  This one is a wedding present.

thanks

jason

I was concentrating on my problem, allbeit mistakenly, but since I have discovered you I have just checked out your products and this stuff is pretty cool.

Just so that you know that by responding to my queries in such a profecient (and patient) manner, you have gained a customer!

thanks again

jason

Problem solved thanks to your help

var fo = new SWFObject("flip_guestbook.swf?"+Math.round(Math.random()*10000), "flip_guestbook.swf", swfWidth, swfHeight, "8" );

thanks
jason

Hi steven

Thanks for clearing ity up.

So my next question is can autoviewer be used to put a flash file such as this on my webpage?

thanks
jason

I appologize for those multiple posts.  Something is slow:)

jason

This is how the guestbook is being viewed.

This is not autoviewer?

<div id="flashcontent">AutoViewer requires Adobe Flash. <a href="http://www.macromedia.com/go/getflashplayer/">Get Adobe Flash.</a> If you have Flash installed, <a href="index.html?detectflash=false">click to view gallery</a></div>   


    <script type="text/javascript">
        var swfWidth = 590;
        var swfHeight = 300;
        var fo = new SWFObject("flip_guestbook.swf", "viewer", swfWidth, swfHeight, "8" );
        fo.addParam("scale", "noscale");
        fo.addParam("quality", "best");
        fo.addParam("wmode", "transparent");
        fo.write("flashcontent");   
        fo.addVariable( "langOpenImage", "Open Image in New Window" );
        fo.addVariable("langAbout", "About");   

    </script>   

Jason

Here is the file

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <img_back>img/back.jpg</img_back>
    <phpURL>php/guest.php</phpURL>
    <alert_color>#FF0000</alert_color>
    <name_color>#8d2405</name_color>
    <message_color>#532b2b</message_color>
    <datePosted_color>#307a03</datePosted_color>
    <insert_ok><![CDATA[<font color='#0f5711'>Thanks for the message.</font>]]></insert_ok>
    <insert_error><![CDATA[<font color='#ff0000'>Error adding Message</font>]]></insert_error>
</configuration>

The config.xml has the link to the phpURL which connects to the MySql database.

jason

This is my first time using autoviewer.  Luckily this isn't a commercial site so I have time to work this out.

jason

Hi Steven

I had tried xmlURL and then phpURL and made the typo when I changed it back so you could check it out.

Still doesn't work.

thanks

jason

Hi

I have a guestbook which loads perfectly on the first time the page is accessed.  When I navigate from and back to the page my viewer shows up but not the entries from the database.   When the browser cache is emptied everything is fine when I navigate back to the page.  My config.xml file has the phpURL.

Tried

fo.addVariable("xmlURL", "config.xml?nocache="+new Date().getTime()); (saw  it  here)

No good..but I have only one xml file.

Did the usual no-cache metra stuff including 2nd header at bottom of page...no good.

When you go to the page it is ok, but when you navigate back to the page you should see entries on the left side.  If you post a messager at that time it does not show up immediately as it should, but it does show up after the temp internet files have been deleted.

Any help with this problem will be greatly appreciated.

http://nealandjessie.com/guestflip/indextrynocache.html

Thanks

jason