Just tried baseURL, worked perfectly. Will change all other documents and report back.

Thank you so, so much for the help Steven!

So I put the painting.html doc into a subfolder with the gallery, backlinking all the files -- it works well.

However, this basically means that my URLs will have to read as:

Hmm... it would have been nice to have something cleaner...

I'm working on an art portfolio site which is organized like so:



illustration.html (needs viewer gallery)

painting.html (needs viewer gallery)

inklings.html (needs viewer gallery)

toys.html (needs viewer gallery)

process.html (needs viewer gallery)

There are NO subfolders. Everything is located in public_html.

I now have a working SV viewer in my painting.html div. I need to create four more galleries with the same viewer customizations, but different images/thumbs. I've downloaded and read the provided .zip files ( + but can't understand the way it's been organized.

Do I need to place all my non-index.html documents which need viewers (illustration.html, toys.html, etc.) into a subfolder with a new gallery.xml doc, for the specific gallery to link properly?

In the .zip sample, I also see that swfobject.js and viewer.swf are located in the multiple gallery's subfolders. These docs are originally in svcore -- do I copy those files again? Is that necessary? Is each svcore folder specific to the created gallery (with images) or is it a root file?

Basically, I don't understand which files are specific to the particular gallery, and which need only one copy for the viewer to function on the site as a whole.

I'd like to find the cleanest way of organizing these files... I really appreciate any help.

I need to get my portfolio site up ASAP.

Thanks in advance!

Thank you Steven! It works beautifully now!

My 'thumbs' and 'images' folders were set at permissions of 700; is this SV's default when it creates the files? I would never have guessed that the folders were the issue -- I spent hours assuming it had something to do with the code or individual files. Anyway I changed my perms directly on cPanel.

Thanks again! I didn't expect this to be resolved so quickly!  :)

Hi All,

I can't understand what's wrong...  :/

This is my site:

I placed my gallery within a div on my index.html page and it works fine locally, but once published I'm getting that white "X" and have looked through numerous posts and have exhausted all conceivable options.

What I've tried so far:

- Hotlink protection is disabled

- Used Cyberduck as my FTP client initially: when I saw the likelihood of my .swf file being the issue, I used Dreamweaver's FTP (binary) and also tried to manually upload the two .swf files directly into my cPanel. Still no difference.

- My paths and names in gallery.xml are correct (I also changed images/~.jpg to in the gallery.xml file and it didn't make a difference).

- Folders are organized (gallery.xml is beside index.html)

Please help and thanks in advance! Let me know if you need more info.