Topic: Gallery not displayed in Firefox

Hi there, I have a wordpress gallery pro version running Version 2.3.2.4 and I can't seem to get the images displayed in Firefox, working in Google chrome. Images are pulled from Flickr and can be viewed in Firefox when in the full screen mode but nothing is displayed except the icon to go to full screen. Also so images are not scaling properly in chrome, example link http://03e.ac1.myftpupload.com/1st-birthday/

Here is my code:
titlePosition="none"
imageScaleMode="scale_up"
changeCaptionOnHover="true"
changeImageOnHover="true"
imageNavStyle="classic"
thumbNavStyle="classic"
stageVPadding="0"
stageHPadding="10"
floatButtonBar="true"
buttonBarHAlign="right"
imageVAlign="top"
thumbVAlign="top"


Max image height/width is set to 1000 and gallery width set to 100%.

I'm wondering what I am doing wrong, I believe it was working before the update of the plugin.

Thank you in advance for your support!

Re: Gallery not displayed in Firefox

There is currently a known incompatibility between SimpleViewer galleries and themes which load the FitVids JavaScript code.
I'm not sure which external JavaScript file within your web page contains FitVids but it certainly seems to be present.
FitVids sees the SimpleViewer SWF file as a video and tries to change its size, causing problems.
I have notified the developers of this problem and it should hopefully be fixed in a future version of SimpleViewer.
In the meantime, the order in which the SimpleViewer and FitVids JavaScript files are loaded seems to make a difference and the following suggestion (which will hopefully load the SimpleViewer JavaScript file after the FitVids code) should be a suitable workaround.
In WP-SimpleViewer v2.4.2.4, open the 'wp-simpleviewer/wp-simpleviewer.php' file in a plain text editor and replace the shortcode_check function (lines 153 to 169 inclusive) with the following:

/**
 * Shortcode check
 *
 * @param array posts
 * @return array posts
 */
function shortcode_check($posts) {
    if (!empty($posts) && !is_search() && !$this->required_core) {
        foreach ($posts as $post) {
            if (preg_match('/\[simpleviewer.*?gallery_id="[1-9][0-9]*".*?\]/i', $post->post_content)) {
                $this->required_core = true;
                add_action('wp_enqueue_scripts', array(&$this, 'add_scripts_wp_core'));
                break;
            }
        }
    }
    return $posts;
}
Steven Speirs
SimpleViewer Support Team

Re: Gallery not displayed in Firefox

That workaround seems to be working.

Thank you very much for the fast response and a working solution :)

Re: Gallery not displayed in Firefox

I'm glad that works. Thank you for posting back to let me know.
This workaround will be included in the next version of WP-SimpleViewer but hopefully the underlying problem which affects SimpleViewer itself can be fixed in a future version.

Steven Speirs
SimpleViewer Support Team