Topic: Struggling with a few mobile issues?

Good-morning,

I am using SV Pro 2.3.2 on two different websites and I am getting different mobile functionality and I can not for the life of me figure out why?

All on the iPad 4

On site A it loads the thumbnail  grid first (preferred) but on Site B it loads the first image?

Also on site A I can swipe form left to right without being in Full Screen (preferred) - but on Site B I can not swipe UNLESS I am in full screen?

I am very confused as to which settings might be different?

Please advise.

Warm regards,
Chris Sgaraglino

Re: Struggling with a few mobile issues?

Please post the URLs to your two galleries so that I can see the problems for myself and check the configuration options used in both galleries.

On site A it loads the thumbnail  grid first (preferred) but on Site B it loads the first image?

This sounds like Gallery B might set mobileShowThumbs="FALSE" or use a firstImageIndex (either of which will skip the thumbnail page).

Also on site A I can swipe form left to right without being in Full Screen (preferred) - but on Site B I can not swipe UNLESS I am in full screen?

I'm not sure why this would be but hopefully I will be able to determine the cause of the problem when I see your gallery. Perhaps there is some conflicting CSS or JavaScript code on the web page into which your gallery is embedded. I will know more when I see your gallery.

Steven Speirs
SimpleViewer Support Team

Re: Struggling with a few mobile issues?

Thanks for the quick response - as you suggested it is the firstImageIndex that is causing it to use the first image and not thumbs.  I'll need to update my XML builder to allow that to be empty - right now it forces to 0.

I'm not real sure what I did - but I seem to have fixed the swipe issue...

If you interested in seeing your tool working on Desk, Tablets & Phones - take a loot at these links.

At this page: http://classichomes.com/index.cfm?id=1a … 50f44dae7c
If you click Search For Homes you'll get a set of results with which the EXTERIOR View is a SV Album.

On both the iPhone and the iPad - it is also (finally) working in a responsive manner.
If you go to http://www.classichomes.com and Select Floor Plan Search form the Mobile Menu it will take you to the search screen - where you can preform the same search.

Warm regards,
Chris Sgaraglino

Re: Struggling with a few mobile issues?

I'm glad everything seems to be working OK at the moment.
Thank you for posting back to let me know.

Just in case you are interested, you might be able to load your SimpleViewer gallery into Shadowbox without the need for vertical and horizontal scrollbars by setting your gallery dimensions (in the embedding code) to 100% x 100% (so that the gallery fills the Shadowbox no matter what its size). I just thought I'd mention it in case it helps.

Steven Speirs
SimpleViewer Support Team