Topic: Config.xml now gallery.xml?

Upgraded to 2.3.2 from 2.1.x  Now getting gallery.xml not found when trying to open the existing galleries. But none of my galleries have gallery.xml (we have quite a few galleries). But, that do have config.xml. Is this the same file and I simply need to rename it to gallery.xml??

Re: Config.xml now gallery.xml?

Upgraded to 2.3.2 from 2.1.x

Nothing has changed with regard to the structure of galleries from v2.1.0 to v2.3.2 so the problem is unlikely to be directly related to the upgrade.

Now getting gallery.xml not found when trying to open the existing galleries.

Are you referring to:
(1) opening a gallery in svBuilder-Pro to edit it
.. or:
(2) opening a gallery in a browser to view it?

If #1:
In order to open a SimpleViewer gallery in svBuilder-Pro, you need to select the gallery folder (the folder containing the 'gallery.xml' file).

If #2:
Please see this FAQ which might help:
When I view my gallery I see the message 'Gallery XML Not Found'. How do I fix this?

But none of my galleries have gallery.xml (we have quite a few galleries).

Every gallery created by svBuilder-Pro will have an XML file named 'gallery.xml' file inside the gallery folder. There is no user control within svBuilder-Pro to change the name of the XML file so there should always be a 'gallery.xml' file.
The XML file used in Juicebox galleries is named 'config.xml' by default.

But, that do have config.xml.

Are you maybe trying to open a Juicebox gallery in svBuilder-Pro? If so, this will not work.

Is this the same file and I simply need to rename it to gallery.xml??

If you just rename a gallery file (in order to try to open it in svBuilder-Pro), the gallery will fail to display in a browser.
If you rename a SimpleViewer gallery's XML file, then you would need to use the galleryURL configuration option (within your gallery's embedding code) to point towards it.

I really need some more information in order to help further.
Please let me know how you are creating your SimpleViewer galleries (the ones with the 'config.xml' files). I do not know of any method which creates 'config.xml' files (except for the WordPress plugin WP-SimpleViewer which generates galleries dynamically and those cannot be opened by svBuilder-Pro).

Also, it might help if I had access to one of your galleries so that I can try to replicate the problem myself.
Please zip one of your galleries and upload it somewhere or email it to me so that I can investigate further.
Thank you.

Steven Speirs
SimpleViewer Support Team

Re: Config.xml now gallery.xml?

Turns out some of our galleries were created with Simple Viewer Pro, and some with Juicebox Pro.  :rolleyes:  Argh! Feel free to delete this thread!

Re: Config.xml now gallery.xml?

Don't worry. It's an easy mistake to make. I'm just glad we found the reason for your problem.
Incidentally, it is possible to open a SimpleViewer gallery in JuiceboxBuilder (to convert the SimpleViewer gallery to a Juicebox gallery) but not vice versa.
Leaving the thread in place might help other users who face a similar problem and search the forum for a term such as 'config.xml'. I hope that's OK.

Steven Speirs
SimpleViewer Support Team