Topic: Did not manage to embed...

Hello there,
I have been using SV pro for a few years now. I used the iframe method because I did not manage to embed in html pages of my wordpress site.
Today, I need to have my galeries responsive, and I am trying to embed with the HTML method.
I do feel ashamed because I really do not see what I have to do to succeed in it... I do create my galleries with sv builder pro.
On this page: http://bbc-bois.com/realisations/maisons-neuves/
you can see the iframe method, and the lines after I tried the html method. In vain;
Could you plz help ?
Thank you.
Nicolas

PS any method to move from SW pro 1 to SW pro 2 ? Any special need to do it ? Thx

Re: Did not manage to embed...

Your embedding code looks OK.
I think the problem might be that your web page seems to be combining and minifying all your JavaScript files into one big file which will likely break SimpleViewer.
Exclude the 'simpleviewer.js' JavaScript file from your WP-Minify plugin and load the 'simpleviewer.js' file into your page (just above the embedding code should be fine) as follows:

<script type="text/javascript" src="http://bbc-bois.com/0www.wp/wp-content/uploads/galerie-realisation-maisons/svcore/js/simpleviewer.js"></script>

PS any method to move from SW pro 1 to SW pro 2 ?

Your gallery already uses SimpleViewer-Pro v2.1.1. You can check the version number in the comments at the top of the 'simpleviewer.js' file.

Any special need to do it ?

The main advantage that v2.1 onwards has over v1 is Universal Playback: the ability to display the gallery on non-Flash-enabled devices.
As a SimpleViewer-Pro v.2.1.1 user, you can upgrade tot he current version for free by following the instructions on the Upgrading SimpleViewer page.
Please see the Version History for a full list of changes between versions.

In case you are not already aware, there is a SimpleViewer plugin for WordPress (WP-SimpleViewer) which will allow you to create and embed galleries directly in pages or posts from within the Dashboard without the need for any manual coding at all. You can download WP-SimpleViewer from its support page here.

Also, please take care when giving your gallery a percentage height. You may need to ensure that all parent containers of your gallery have been assigned heights via CSS. Otherwise, SimpleViewer might not be able to determine what its actual height should be. This can be difficult to do in a WordPress environment which is why the default height for a WP-SimpleViewer gallery is 600px (and not a percentage).
Please see the note regarding Using Percentage Heights here.

I hope these notes help.

Steven Speirs
SimpleViewer Support Team

Re: Did not manage to embed...

Hello Steven,
Thx so much for your quick answer. Indeed, I installed that WP-minify plugin.
I will try to exclude 'simpleviewer.js' file as per your advice and will let you know.
Thx also for your comprehensive answer on the advantages moving to latest SW version.
Kindly,
Nicolas

Re: Did not manage to embed...

Steven,
I excluded SV.js from WP-Minify plugin, not working.
Even tried to desactivate WP-Minify plugin, but still not working.
Any other clue ?
Nicolas

Re: Did not manage to embed...

Hello Stevens,
I moved to v2 tried again on another page:
Sounds far better. But gallery.xml is not found.

I thus tried with flashvars, but adding the code makes the container not appear on screen.
By calling simpleviewer.load with path inline, without flashvars, is better. But gallery still missing;

Btw, I totally desactivated Minify, cause excluding sw.js only had no effect.
Thx
Nicolas

Re: Did not manage to embed...

Hi, me again...
I think the "XML gallery not found" is not a matter of path. Container displays now, event with WP Minify extension ON.

It may be due to sv1 to sv2 migration.
I thus created a new gallery from scratch with svbuilder2 (not the pro one) and uploaded to the server. But nothing.
http://bbc-bois.com/societe/

Thx
Nicolas

Re: Did not manage to embed...

At the moment, on your 'maisons-neuves' page, your 'simpleviewer.js' file is still being loaded as part of a larger file by WP-Minify and this is almost certainly the cause of the problem on your main page. The 'simpleviewer.js' file needs to be loaded on its own from within the gallery's 'svcore' folder.

The problem with your new gallery is that it is not possible to just enter the path to the gallery folder as the flashvars Embed Code Parameter. You need to use a baseURL . (Also, the path is incorrect.)
Change:

simpleviewer.ready(function () { simpleviewer.load("sv-container", "650", "400", "transparent", true, "/www/0www.wp/wp-content/uploads/galerie-societe"); });

... to either:

var flashvars = {};
flashvars.baseURL = "/0www.wp/wp-content/uploads/galerie-societe/";
simpleviewer.ready(function () {
    simpleviewer.load("sv-container", "650", "400", "transparent", true, flashvars);
});

... or:

simpleviewer.ready(function () {
    simpleviewer.load("sv-container", "650", "400", "transparent", true, { baseURL: "/0www.wp/wp-content/uploads/galerie-societe/" });
});
Steven Speirs
SimpleViewer Support Team

Re: Did not manage to embed...

YEEEEEES !
Thank you so much for your time , Steven !!
I am really happy to use SimpleViewer, that is high above other viewers I found. And happy to use it HTML embedded.
Thx !
Nicolas

Re: Did not manage to embed...

I'm glad you've got it working.
Thank you for posting back to let me know.

Steven Speirs
SimpleViewer Support Team