Topic: Out of date Version of jQuery

Hello,
When running a security scan on a website with a simpleviewer gallery I'm getting back a vulnerability stating the jQuery version used in my updated version of simpleviewer is out of date. It's recommended that I upgrade from jQuery 1.5.2 to 1.12.3. How can I update jQuery in simple viewer? If that can't be done, how can I rectify this problem? Thanks for your help

Re: Out of date Version of jQuery

SimpleViewer comes bundled with a version of jQuery for its own internal use. (It simplifies the gallery embedding process by avoiding the need to manually include a separate version of jQuery in the gallery web page.)
This version of jQuery cannot be changed. It is included in the 'simpleviewer.js' JavaScript file which is packed and obfuscated. and cannot be modified.
You can still include a more recent version of jQuery in your web page if you like (to take advantage of new jQuery features) but the version bundled within SimpleViewer will remain. Unfortunately, there is nothing that you can do to remove or change it.

The best I can suggest is that you maybe post a request to update the internal jQuery version in the Feedback and Feature Requests forum thread.
This keeps all the ideas together and ensures that they are not overlooked by the developers.
Thank you.

Steven Speirs
SimpleViewer Support Team

Re: Out of date Version of jQuery

Thanks Steve,  I'll post the request to the Feedback and Feature Requests thread.

Re: Out of date Version of jQuery

Thank you for posting in the Feature Requests thread.
It's the best place for all feedback and ideas.

Steven Speirs
SimpleViewer Support Team