Topic: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

Hi, my site (www.loveworkflow.com) is no longer working on my late 2015 iMac lately. 
When I said lately, I mean it used to work when my iMac was running on OS 10.12(Sierra). It stopped working after I downgraded the system to OS 10.11 (El Capitan).

In El Capitan, the Chrome showed the site, but lost the movement and capability of enlargement of any images, it just sits idly.

I recently used TimeMachine to restore my system back to Sierra, the problem persists. (This is where it puzzles me.)
I believe I have the Flash & Java set correctly in Chrome's preference (Both are checked: Allow sites to run on Flash and Java), unless I'm missing something.

It works on Safari (after I downloaded and installed the flash player). 

My laptop has the same Chrome version, and it works perfectly.
Can you help?

Thank you so much of your time,
CJ

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

Just for the record, your TiltViewer gallery displays and functions fine in Chrome 55 on my Windows 10 PC.

There is no known issue for TiltViewer in Chrome on El Capitan.
It certainly sounds like a Flash Player problem in your El Capitan Chrome browser.

Check that your Adobe Flash Player installation is up to date by visiting this web page in your browser: https://helpx.adobe.com/flash-player.html

Also, try the suggestions on this Chrome help page: https://support.google.com/chrome/answer/6258784?hl=en

It might also be worth trying to completely reset Chrome: https://support.google.com/chrome/answer/3296214?hl=en

Your TiltViewer gallery should work OK in your Chrome browser so persevering and trying the suggestions above should hopefully help.

Steven Speirs
SimpleViewer Support Team

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

Hi Steven,
Thanks for your speedy response.
I will work on it and report back.

Very much appreciated of your time and effort of providing all the possible solutions.

Best,
CJ

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

You're welcome.
I hope you're able to get your TiltViewer gallery working in your Chrome browser.

Just in case you're looking for another test gallery to check things with, you could always try viewing our own TiltViewer demo gallery here.

Steven Speirs
SimpleViewer Support Team

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

Thanks Steven,
So I did few things, and none of them worked:
1.  I trashed and downloaded & reinstalled the Chrome.  Result:  no change. 
2.  I downloaded & installed the PPAPI (https://helpx.adobe.com/flash-player/kb … hrome.html), I re-started the computer and tested.  Result:  no change. 
3.  Prior to this Chrome & Flash combo problem, I remember I installed the Canon Utility softwares.  So I trashed the whole Canon software to eliminate if there is any slight chance the software is causing the problem.  Result:  no change.
4.  I reset the Chrome.  Result:  no change.

I typed "about:plugins" to inspect my plug-in, following is the status:   
Adobe Flash Player - Version: 24.0.0.194  /  Shockwave Flash 24.0 r0  / Name:    Shockwave Flash
Description:    Shockwave Flash 24.0 r0 System  /    Version:    24.0.0.194
Location:    /Library/Internet Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin
Type:    PPAPI (out-of-process)
MIME types:   
MIME type                                      Description                           File extensions
application/x-shockwave-flash      Shockwave Flash                     .swf
application/futuresplash               FutureSplash Player             .spl

I noticed that PPAPI is out of process.  Could this be the culprit?

At this point, I'm not sure what else I can do.  Any insight is welcome.
Thanks,
CJ

Last edited by cjlee (2017-01-18 18:51:30)

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

You are using the same version of Adobe Flash Player that I have installed in my own Chrome 55 (on PC) and your gallery displays and functions fine in Chrome on my own PC.

According to an answer in this forum thread, "(out-of-process)" means:

... it runs in a separate compartment and memory space that is distinct and apart from the main browser process and webpages.  This allows stronger security and performance improvements, and ensures that any problems, slowdowns, or security issues in the Flash will not be able to affect the browser, and allows other webpages in other tabs to continue working even if the Flash in one webpage develops a problem.

... so this is unlikely to be the root of your problem.

Do you see the same problem with our own demo gallery here?

I'm really not sure what could be causing your problem.
It sounds unlikely but if you have any security software installed, try temporarily disabling it to see if this makes a difference.

You could also open the Adobe Flash Player Settings Manager in your browser to see if any settings look like they might be causing your issue. Visit this web page in your browser to open the Settings Manager.

Also, you might like to try the suggestions in this web page (although it looks like Flash's days are numbered in Chrome).

Steven Speirs
SimpleViewer Support Team

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

Yes, I have the same problem with your demo gallery.

No, I don't have any security software installed.

Just out of curiosity, I re-installed my OS again with Time Machine.  I found something very interesting:
Once the OS got re-installed, the TiltViewer in Chrome worked fine.  But once I re-started the computer,  I lost the TiltViewer functionality.  Now I'm scratching my head...

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

I think I have finally solved the problem:
I trashed an app (Be Focused.app) today, suddenly all the functionality of the TiltViewer in Chrome
are back again.

I think we can officially close this chapter now.  LOL.

Steven, thanks for all the suggestion and help.
Your suggestion of persevering to solve the issue keep me coming
back to revisit this issue--was a great motivation.  Big Thanks.
Wish you all the best!

Re: Chrome & Tiltviewer & iMac (late 2015) [SOLVED]

I'm glad you've been able to resolve your issue.
Thank you for posting back and letting me know what the problem was.
It may help other users experiencing similar symptoms.

Steven Speirs
SimpleViewer Support Team