Topic: Simple Viewer Gallery stopped working

Hey, i've been using the Simple Viewer Gallery on a website for a few years now and i've never had a problem. This morning i checked the site to see that the gallery has completely stopped working and i'm getting the error message 'No Images Specified in Gallery XML'. I've checked my code and can't see anything which has changed.

Can anyone help me??

Link to gallery: www.specialistcraftsgallery.com/index.html

Re: Simple Viewer Gallery stopped working

The Flash version of your gallery seems to be working OK but not the Mobile version.

It looks like the problem is due to the use of the '&' character in one of your image filenames: "Laura-Griffith,-A-Picture-of-Health,-Acrylic-&-Mixed-Media-on-MDF.jpg".

When an image is uploaded to a web server, its filename forms part of a URL and the '&' character is a reserved character with a special meaning. It would be wise to use only web-safe characters within image filenames. Please see section 2.3 of this document for details.

Characters that are allowed in a URI but do not have a reserved purpose are called unreserved.  These include uppercase and lowercase letters, decimal digits, hyphen, period, underscore, and tilde.

Once you rename this image and its corresponding imageURL, thumbURL and linkURL entries in your gallery's 'gallery.xml' file, your gallery should display correctly.

Incidentally, I notice that your gallery currently uses SimpleViewer-Pro v2.2.0.
You might like to upgrade your gallery to the latest version (v2.3.2) as many bugs have been fixed since v2.2.0.
Please see the Version History page for a list of changes between versions.
Instructions for downloading the latest version and upgrading existing galleries can be found on the Upgrading SimpleViewer-Pro support page.

[Thread moved from SimpleViewer-Pro v1 forum.]

Steven Speirs
SimpleViewer Support Team

Re: Simple Viewer Gallery stopped working

Hello and thank you for getting back to me so fast.

That makes sense, i will change the image file to not have the '&' character in the filename and see if that fixes the problem. I've also installed the new version onto my website

One question though, why has the design of my galleries changed? It used to display like the demo you have 'Modern' but is now just displaying as thumbnails?

Many thanks,
Shaun

Re: Simple Viewer Gallery stopped working

... but is now just displaying as thumbnails?

This suggests that Adobe Flash Player is not installed and enabled in your browser and that SimpleViewer is using the Mobile Player to display the gallery. Please see the note regarding Universal Playback here. (I see the Flash version of your gallery when I view it in my own browser.)

Please see these FAQs:
When I view my gallery I see a grid of thumbnails, not the layout I specified. Why?
The mobile player layout does not match the Flash player layout. Why not?

You can check if Adobe Flash Player is installed correctly and active by visiting this web page in your browser: https://helpx.adobe.com/flash-player.html

If you continue to experience problems with Adobe Flash Player, try uninstalling it and then reinstalling it from this web page: https://get.adobe.com/flashplayer/

If you are using Chrome, then please check the following:
(1) Open Chrome
(2) Click the 'Options' button (the three vertical dots near the top right)
(3) Select 'Settings'
(4) Scroll down to the very bottom
(5) Click the 'Show advanced settings...' link
(6) Scroll down to the 'Privacy' section
(7) Click the 'Content settings...' button
(8) Scroll down to the 'Flash' section
(9) Select 'Allow sites to run Flash'
(10) Click the 'Done' button at the bottom right

SimpleViewer is predominantly a Flash image viewer and the Mobile Player was designed as a fallback mechanism (so that non-Flash-enabled browsers and mobile devices can still display the images) rather than a fully-featured image viewer within itself. As such, the Mobile Player supports fewer configuration options than the Flash Player.

At least the Mobile Player within SimpleViewer allows your gallery images to still be displayed and viewed even if Adobe Flash Player is not installed and enabled in the browser being used to view the gallery. (Prior to the Mobile Player being introduced in v2.1.0, SimpleViewer was purely a Flash gallery and just displayed a "Flash Player required." message instead of any images at all if Adobe Flash Player was not available.)

If you are looking for a more fully-featured non-Flash image viewer than the Mobile Player within SimpleViewer, then you might like to take a look at another one of our products, Juicebox.

Juicebox is a HTML 5 image viewer which does not use or rely on Adobe Flash at all. Juicebox-Pro has very similar configuration options to the Flash Player within SimpleViewer-Pro and the majority of Juicebox-Pro configuration options are supported on all devices.
For reference, a list of all Juicebox-Pro configuration options can be found here.
We also have several Juicebox demo galleries here.

For more information on the differences between SimpleViewer and Juicebox (and for details of a 30% discount off the price of Juicebox-Pro for existing SimpleViewer-Pro users), please see this SimpleViewer blog entry.

Please also see this blog entry entitled The End of Flash and What this Means for SimpleViewer.

I hope the information and links above help to clarify things.
If you have any further queries, please let me know.

Steven Speirs
SimpleViewer Support Team

Re: Simple Viewer Gallery stopped working

Hello,

Thank you getting back to me.

Yes, the thumbnails are displaying now but like you said it's fallen back to the mobile layout. I think you're right in saying it's something to do with my flash on the browser.

I think i would like to go for the JuiceBox Pro software instead, i see you mentioned a 30% discount for SimpleViewer Pro users. We got this software back in 2012 so i'm not sure what details i have.

What's the process in buying JuiceBox Pro and applying the 30% discount?

Many thanks,
Shaun

Re: Simple Viewer Gallery stopped working

What's the process in buying JuiceBox Pro and applying the 30% discount?

Please check your email. I have sent you a message.
Just forward me your SimpleViewer-Pro transaction details (Name and Email Address used for purchase, Date of purchase, Transaction ID if applicable) and I'll send you a link which you can use to purchase Juicebox-Pro with the 30% discount.
Don't worry if you can't find or remember all your transaction details, just provide me with as much information as you can (e.g. possible email addresses that you might have used at the time) that might help me find your transaction in our records.
Thank you.

Edit:
Many thanks for providing your SimpleViewer-Pro transaction details.
I have sent you the links to purchase Juicebox-Pro (Single-Site or 5-Site license) with the 30% discount.

Steven Speirs
SimpleViewer Support Team