Topic: Problems publishing viewer.fla

I would like to turn off the clickwheel functionality, so I edited per the instructions, opened simpleviewer.fla, and selected publish.

I receive the following error, and the resulting viewer.swf file does not work properly:, Line 263 - There is no property with the name 'buttonFrame'. - mPlayBtn.buttonFrame = mPlaying ? 1:2:

Can anyone advise me on how to fix this issue?  I have tried downloading again, but I get the same error.

I am using Adobe Flash CS3 Professional - version 9.0


Re: Problems publishing viewer.fla

Hi, I'm unable to reproduce this issue. Are you sure you are using the latest source files when you are publishing your SWF? Check your Flash IDE AS2 settings are not referencing an old version of the code. Edit->Preferences->ActionScript->AS2 Settings...

Felix Turner
SimpleViewer Support Team.

Re: Problems publishing viewer.fla

I have been able to correct the issue.  Thank you for pointing me in the right direction. 

For future reference in the event that someone else has a similar issue, I tried three things, one or more of which may have resolved the issue. 

-I changed the global as2.0 class path to be an absolute path.
-I removed .aso files in the default path that I suspect may have been created during a previous publishing and may have been out of date (the first time I downloaded simpleviewer-pro I had some corruption issues).
-I created a new as2.0 path pointing towards the simpleviewer .as files and placed it at the top of the path list.

I know very little about actionscripting, so if someone more knowledgeable would like to explain exactly what I did and why it worked, it would be helpful.

Re: Problems publishing viewer.fla

Well, the first issue has been resolved, but I am afraid I am not there yet.  My reason for re-publishing the .swf was to remove the clickwheel funtionality.

Why?  Because I want the user to be able to scroll down the webpage normally, regardless of whether the pointer is over the simpleviewer object or anywhere else on the page.

Disabling the EnableMouseWheel prevented simpleviewer from reacting to the mouse wheel, but when the pointer is over the simpleviewer object, the page will not scroll.  If the simpleviewer object is selected, either by clicking on a thumbnail or on the main image, the page will not scroll until the user clicks outside of the simpleviewer object.  Is there any way to resolve this?

CN - I want the mouse wheel to cause the webpage to scroll, even when the mouse is over the simpleviewer object and after the simpleviewer object has been selected.

Re: Problems publishing viewer.fla

Got it.  While the AS option EnableMouseWheel will disable the functionality of the scrollwheel, the listener is still enabled, and so the mousewheel does not scroll the page when the focus is on the simpleviewer object.

Removing the mouse listener resolved the problem.  Might I suggest to Felix that, while more convenient, the AS option EnableMouseWheel is not a very clean method for removing this functionality, and I would suggest that if someone does not want the mousewheel option, they should remove the listener altogether.

Instructions for removing the listener:

To disable mousewheel support, remove this line in ThumbArea.init():


Re: Problems publishing viewer.fla

Good catch - thanks! I've updated the SV-Pro source code to disable the listener if 'enableMouseWheel' is false. Use your original download link to get the latest files.

Felix Turner
SimpleViewer Support Team.