Topic: Strange inconsistant thumbs permissions problem

Well....this one has me utterly stumped!

Having got svmanager and sv pro working perfectly, I let my client loose on it.

He reported that after uploading images (with no errors, and image thumbs visible within svmanager), none of the images he uploaded appeared in the actual simpleviewer gallery - only "X"s where the thumbnails should be.

I took a look on the server itself and found that while the images had the correct 644 permissions, the thumbs were 600, hence the problem. I was puzzled, because it had worked perfectly for me.

So I tried uploading a single image again myself using svmanager. Low and behold, the thumb was 644 and all was well.

I then deleted it and uploaded it again.

Mysteriously the thumb was 600 this time and therefore not visible in simpleviewer!

I renamed the file and uploaded it again. 644 this time, and all well!

I deleted it and reuploaded. 600 this time.

Doing a re-build makes no difference.

In other words, I'm seeing inconsistancy in terms of the permissions given to the uploaded thumbs - but not the actual image files.

The permissions and ownership on the actual gallery image and thumbs folders are indentical. They were not 755 but they are now, but that makes no difference.

I'm utterly mystified. Utterly! Any suggestions?


Re: Strange inconsistant thumbs permissions problem

OK, this is getting stranger.

The inconsistant permissions on the files remains BUT it seems I was wrong, and permissions of 600 on the thumbnail actually does NOT stop the image from being served/viewed when the permissions on the actual directories are set to 755. At least that's what I think at the moment. Gods I'm confused, but I think I've cracked the actual problem.

The inconsistant permissions issue remains, however. No php errors reported, even with debug mode set to true, nothing in any log anywhere on the server apart from (initially) file not found on the thumbnails set to 600 when the dirs were not 755.


Re: Strange inconsistant thumbs permissions problem

Very strange indeed. Some servers set rather strange permissions but I've never seen one that keeps changing its mind.

There are some settings in the svmanager/includes/constants.php file that affect permissions (if the server allows it). There's no setting for new thumbnail permissions – nobody's ever needed that one before. However, you may want to play around with the settings for new directories. They are commented in the file so you should be able to work out what does what.


Jack Hardie
SimpleViewer Support Team.

Re: Strange inconsistant thumbs permissions problem

Thanks Jack. Will do.