Topic: Thumbnails not generating despite Created Thumbnail response

Hi everyone...

The problem, using 1.8: Despite following the Automatic Web Server instructions perfectly (and several times over to be on the safe side), I continue to only see white "X"s where the thumbnails should be. I've read several other posts that sounded similar, but none seemed to match this problem. If someone knows of a post that fits the following and offers a solution, please let me know.

The details:

1) I went through the entire process going through the following steps. I unzipped, and I then unzipped into the same simpleviewer directory. I put a few test photos into the images folder, and I then uploaded all of those files into a folder called test01.

2) I then change permissions with the Panic Transmit (OS X) FTP client, as follows:

buildgallery.php - 777 rwxrwxrwx
gallery.xml - 666 rw-rw-rw-
thumbs - 666 rw-rw-rw-

I then confirm the permissions for each to make sure.

3) In Firefox, I navigate to (the location of this particular test run's build script)

A moment later I get the following response:

Creating XML and thumbnails for SimpleViewer.

Sorting images by date.
Sorting images in reverse order.

- Created Image Entry for: 013_14A.JPG
- Created Thumbnail for: 013_14A.JPG
- Created Image Entry for: 011_16A.JPG
- Created Thumbnail for: 011_16A.JPG
- Created Image Entry for: 010_17A.JPG
- Created Thumbnail for: 010_17A.JPG

Successfully created XML document: gallery.xml

4) At that point it looks like everything went perfectly. Thumbnails seem to have been created for all three images in the images folder. However, when I load the page, the active image appears, but the thumbnails show white "X"s, as illustrated in this screenshot: ( By the way, the directory discussed here is at )

5) I then confirm by FTP that there indeed are no thumbnails in the "thumbs" folder, despite the response detailed above stating that the thumbnails were created.

So, with all of that said, I've tried all of this repeatedly in different ways, with slightly different permissions, etc, and I've had nothing but the same result. I also went in to buildgallery.php and made the useCopyResized = true change, to no avail.

If anyone has any advice on this, or knows of any posts that already covered this specific problem, PLEASE let me know. I'm anxious to use 1.8, but I have no idea when the iPhoto Export app will be updated for that version... (anyone know?)


Re: Thumbnails not generating despite Created Thumbnail response

OK, I figured it out. I'm leaving this post on here rather than deleting it in case it ends up helping someone with the same problem.

My permissions were wrong. In order to get the thumbnails to -actually- generate inside the thumbs folder, I had to use the following permissions:

buildgallery.php: 777 rwxrwxrwx (read write execute at all levels)
gallery.xml: 666 rw-rw-rw- (read and write at all levels)
thumbs: 777 rwxrwxrwx (read write execute at all levels)

I couldn't figure out the solution until I found info on the web that more clearly explains the difference between permissions for documents and permissions for directories. But the instructions on the SimpleViewer server-side scripting page state "Set file permissions on the build script to 'execute'. Set file permissions on gallery.xml and thumbs folder to 'write'. You can do this with your FTP program, check the documentation" which led me to use 666 for both gallery.xml and thumbs. It might help to add the actual permissions commands to the instructions. But aside from all of this, the SimpleViewer is awesome... thanks so much for a great tool.


Re: Thumbnails not generating despite Created Thumbnail response


thanks for the catch! I will update the docs accordingly.

- Felix

Felix Turner
SimpleViewer Support Team.